Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4032 closed defect (fixed)

HTTPS Everywhere breaks "see all videos" and "large window" in YouTube

Reported by: Alan_De_Smet Owned by: OsamaK
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: tomchiverton, trac.torproject.org@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

(The links below might not be safe for work, there is some swearing. It happens to be the pages I was looking at when I identified HTTPS Everywhere as the trigger.)

When viewing a specific YouTube video (eg http://www.youtube.com/watch?v=SzEc3o7pVgo&feature=channel_video_title ) There is in the bottom right of the video sub-window arrows pointing right and down; clicking it makes the video portion of the web page larger (but not full screen). When HTTP Everywhere is enabled, this no longer works.

When looking at a user page (eg http://www.youtube.com/user/MyHarto ) in the upper right portion of the page is an icon of a three by three grid of boxes; it changes the page to show all of a user's videos in a grid. When HTTP Everywhere is enabled, this no longer works.

I am not using any custom rulesets. For both cases, I have NOT enabled the YouTube rule, which defaults to off since it's buggy. I have tried turning all of the Google related rules (API, Search, Images, and Services) and restarting Firefox, that doesn't help. Disabling HTTPS Everyhwere entirely and restarting Firefox fixes the problem. I disabled all of my other add-ons and re-confirmed both the working and non-working cases.

Firefox 6.0.2
HTTPS Everywhere 1.0.1
Linux (Ubuntu 11.04)

If there is other information I can provide that will help, please let me know.

Child Tickets

Change History (11)

comment:1 Changed 8 years ago by tomchiverton

Cc: tomchiverton added

I get the same thing here, same O/S.

There aren't any JavaScript errors logged I can see.

The extension shouldn't be doing anything on this page at all so it's all a bit weird.

comment:2 Changed 8 years ago by pde

Owner: changed from pde to OsamaK
Status: newassigned

Osama, are you interested in trying to squash this?

comment:3 Changed 8 years ago by gene_wood

I can confirm the same problem on both my machines (Firefox under Ubuntu and Firefox under WinXP). I finally figured out it was being caused by https everywhere after disabling add-ons.

comment:4 Changed 8 years ago by gene_wood

Cc: trac.torproject.org@… added

comment:5 Changed 8 years ago by tomchiverton

Not fixed in the 2.0developement1 build available from https://www.eff.org/https-everywhere btw

comment:6 Changed 8 years ago by pde

Observation 1: this does not seem to happen in the HTML5 trial.

comment:7 Changed 8 years ago by pde

Observation 2: turning on the YouTube ruleset (which may still be buggy for some embedded vidoes) fixes this for me.

comment:8 Changed 8 years ago by pde

Resolution: fixed
Status: assignedclosed

AFAICT, we no longer have embedded video breakage from the YouTube ruleset, so I'm going to turn it on. That should fix this bug as of the next development release....

comment:9 Changed 8 years ago by tomchiverton

What version is that ? Is it worth trying the 1.0.3 build for instance ?

comment:10 Changed 8 years ago by pde

The fix will be in 1.0.4 and 2.0development.2.

comment:11 Changed 8 years ago by tomchiverton

Seems fixed here with https://www.eff.org/files/https-everywhere-2.0development.2.xpi - the video resizes put sometimes doesn't play (just a grey square) but I think that's Adobe's fault at that point.

Note: See TracTickets for help on using tickets.