Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#4063 closed defect (fixed)

Tor 0.2.2 CBT notices are confusing users

Reported by: arma Owned by: StrangeCharm
Priority: Medium Milestone: Tor: 0.2.2.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Now that Tor 0.2.2 has gone stable, ordinary users are experiencing the log lines like:

    log_notice(LD_CIRC,
               "Based on %d circuit times, it looks like we don't need to "
               "wait so long for circuits to finish. We will now assume a "
               "circuit is too slow to use after waiting %ld seconds.",

We should turn as many of them into info lines as we can.

Child Tickets

Change History (5)

comment:1 Changed 8 years ago by StrangeCharm

Owner: set to StrangeCharm
Status: newaccepted

comment:2 Changed 8 years ago by StrangeCharm

Status: acceptedneeds_review

Proposed fix available in branch ticket-4063 of git://github.com/flamsmark/tor.git

comment:3 Changed 8 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

Looks good to me!

Two cosmetic things I'll fix up:

First, the issue is in maint-0.2, but you based your ticket-4063 branch on the master branch which means that I can't merge your branch onto the maint-0.2.2 branch without accidentally pulling in the whole of master. Fortunately, it's just one commit, and "git cherry-pick" makes it easy to backport those.

Second, by convention we make a new file in the 'changes' directory for everything that will require a changelog entry in the next release. I'll add one here.

Thanks again!

comment:4 Changed 7 years ago by nickm

Keywords: tor-client added

comment:5 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.