Opened 8 years ago

Closed 8 years ago

#4067 closed defect (fixed)

Update BwAuthority README

Reported by: aagbsn Owned by: aagbsn
Priority: Medium Milestone:
Component: Core Tor/Torflow Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

BwAuthority README should be updated:

  1. Mention compatibility issue between old/new Tors and the option UseMicrodescriptors 0
  1. Add an 'appendix b: postgres support' documenting how to make this work.
  1. Recommend using current versions of sqlalchemy and elixir

Child Tickets

Change History (4)

comment:2 in reply to:  description Changed 8 years ago by arma

Replying to aagbsn:

BwAuthority README should be updated:

  1. Mention compatibility issue between old/new Tors and the option UseMicrodescriptors 0

Tor 0.2.3.4-alpha has a fix:

    - Make 'FetchUselessDescriptors' cause all descriptor types and
      all consensus types (including microdescriptors) to get fetched.
      Fixes bug 3851; bugfix on 0.2.3.1-alpha.

So it's really just Tor 0.2.3.3-alpha that you're incompatible with. I imagine the issue will fade quickly over time.

comment:3 Changed 8 years ago by aagbsn

here's a branch without that section. Thanks for the update!

https://github.com/aagbsn/torflow/tree/4067-update-readme-2

comment:4 Changed 8 years ago by aagbsn

Resolution: fixed
Status: needs_reviewclosed
Note: See TracTickets for help on using tickets.