Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#4089 closed defect (not a bug)

Listening to wrong IP according to log (due to nic alias?)

Reported by: 4ZM Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.2.32
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The log reads:
"Now checking whether ORPort A.B.172.47:9001 and DirPort A.B.172.47:9030 are reachable..."

But the torrc has:
ORListenAddress A.B.172.50
DirListenAddress A.B.172.50

After tor start it really does listen to A.B.172.50 and not to the ip from the log.

The probable cause for this is the use of a physical eth0 with ip A.B.172.47 and an alias eth0:1 with A.B.172.50.

Running on Gentoo.

Child Tickets

Change History (4)

comment:1 Changed 8 years ago by nickm

The *ListenAddress options affect the address that you listen on, not the address that you advertise. Tor binds to the *ListenAddress, but tells everybody else that they can reach your server at the address specified in the Address option -- or at an auto-detected address if you don't specify an Address option. Tor self-tests itself by connecting to the published address, since that's the same one everybody else is going to use.

If you want to bind A.B.172.50 _and_ tell everybody to connect to you at A.B.172.50, then make sure to say "Address A.B.172.50"

comment:2 Changed 8 years ago by 4ZM

Resolution: not a bug
Status: newclosed

Ah, I see.

comment:3 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:4 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.