Opened 8 years ago

Closed 7 years ago

Last modified 18 months ago

#4093 closed defect (fixed)

TBB for OSX logs everything to /var/log/system.log

Reported by: phobos Owned by: erinn
Priority: Immediate Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Normal Keywords:
Cc: erinn, mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

TBB for OS X on 10.5.8 logs everything into system.log in detail. I'm using TorBrowser-2.2.32-4-dev-osx-i386-en-US.

[0x0-0x53d53d].org.torproject.TorBrowserBundle[23756]: Launching Tor Browser Bundle for Linux in /Users/user/Downloads/TorBrowser_en-
US.app/
Sep 25 08:35:36 osxmachine [0x0-0x53d53d].org.torproject.TorBrowserBundle[23756]: dyld: loaded: /usr/bin/open
Sep 25 08:35:36 osxmachine [0x0-0x53d53d].org.torproject.TorBrowserBundle[23756]: dyld: loaded: /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
Sep 25 08:35:36 osxmachine [0x0-0x53d53d].org.torproject.TorBrowserBundle[23756]: dyld: loaded: /usr/lib/libgcc_s.1.dylib
Sep 25 08:35:36 osxmachine [0x0-0x53d53d].org.torproject.TorBrowserBundle[23756]: dyld: loaded: /usr/lib/libSystem.B.dylib
Sep 25 08:35:36 osxmachine [0x0-0x53d53d].org.torproject.TorBrowserBundle[23756]: dyld: loaded: /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreS
ervices
Sep 25 08:35:36 osxmachine [0x0-0x53d53d].org.torproject.TorBrowserBundle[23756]: dyld: loaded: /usr/lib/libobjc.A.dylib

This continues for every framework, dylib, and library loaded and then switches to vidalia:

Sep 25 08:35:36 osxmachine [0x0-0x53e53e].net.vidalia-project.vidalia[23758]: dyld: loaded: /Users/user/Downloads/TorBrowser_en-US.app/Contents/MacOS/Vidalia.ap
p/Contents/MacOS/Vidalia
Sep 25 08:35:36 osxmachine [0x0-0x53e53e].net.vidalia-project.vidalia[23758]: dyld: loaded: /Users/user/Downloads/TorBrowser_en-US.app/Contents/MacOS/Vidalia.ap
p/Contents/MacOS/../Frameworks/QtGui.framework/Versions/4/QtGui
which then logs every framework, dylib, and library loaded by vidalia

and then does it for firefox.

We probably shouldn't be allowing anything to be logged to the system, nevermind in such detail.

Child Tickets

Change History (16)

comment:1 Changed 8 years ago by rransom

Priority: normalblocker
05:58 < rransom__> From src/RelativeLink/RelativeLinkOSX.sh:
05:58 < rransom__>   17 DYLD_PRINT_LIBRARIES=1
05:58 < rransom__>   18 export DYLD_PRINT_LIBRARIES
05:59 < rransom__> Oops.
06:00 < rransom__> And those exact lines are also in RelativeLink.sh (for Linux), although I don't think they do anything there.

comment:2 Changed 8 years ago by rransom

Cc: erinn added
Component: Tor BrowserTor bundles/installation
Status: newneeds_review

See bug4093 ( https://git.torproject.org/user/rransom/torbrowser.git bug4093 ) for a fix.

comment:3 Changed 8 years ago by mikeperry

Cc: mikeperry added
Owner: changed from mikeperry to erinn
Status: needs_reviewassigned

Technically Erinn is the one who needs to merge this.

comment:4 Changed 8 years ago by rransom

Status: assignedneeds_review

comment:5 Changed 8 years ago by erinn

This catches almost everything (thanks!), so I'm happy to merge it, but I still get these:

Sep 29 03:19:58 macbook [0x0-0xc10c10].net.vidalia-project.vidalia[2562]: objc[2562]: Class QCocoaColorPanelDelegate is implemented in both /Users/test/src/tbb-master.git/build-scripts/TorBrowser_en-US.app/Contents/MacOS/Vidalia.app/Contents/MacOS/../Frameworks/QtGui.framework/Versions/4/QtGui and /Library/Frameworks/QtGui.framework/Versions/4/QtGui. One of the two will be used. Which one is undefined.
Sep 29 03:19:58 macbook [0x0-0xc10c10].net.vidalia-project.vidalia[2562]: objc[2562]: Class QMacSoundDelegate is implemented in both /Users/test/src/tbb-master.git/build-sc
ripts/TorBrowser_en-US.app/Contents/MacOS/Vidalia.app/Contents/MacOS/../Frameworks/QtGui.framework/Versions/4/QtGui and /Library/Frameworks/QtGui.framework/Versions/4/QtGui. One o
f the two will be used. Which one is undefined.
Sep 29 03:19:58 macbook [0x0-0xc10c10].net.vidalia-project.vidalia[2562]: objc[2562]: Class QNSOpenSavePanelDelegate is implemented in both /Users/test/src/tbb-master.git/b
uild-scripts/TorBrowser_en-US.app/Contents/MacOS/Vidalia.app/Contents/MacOS/../Frameworks/QtGui.framework/Versions/4/QtGui and /Library/Frameworks/QtGui.framework/Versions/4/QtGui
. One of the two will be used. Which one is undefined.
Sep 29 03:19:58 macbook [0x0-0xc10c10].net.vidalia-project.vidalia[2562]: objc[2562]: Class QCocoaFontPanelDelegate is implemented in both /Users/test/src/tbb-master.git/bu
ild-scripts/TorBrowser_en-US.app/Contents/MacOS/Vidalia.app/Contents/MacOS/../Frameworks/QtGui.framework/Versions/4/QtGui and /Library/Frameworks/QtGui.framework/Versions/4/QtGui. One of the two will be used. Which one is undefined.Sep 29 03:19:58 macbook [0x0-0xc10c10].net.vidalia-project.vidalia[2562]: objc[2562]: Class QNSWindowProxy is implemented in both /Users/test/src/tbb-master.git/build-scrip
ts/TorBrowser_en-US.app/Contents/MacOS/Vidalia.app/Contents/MacOS/../Frameworks/QtGui.framework/Versions/4/QtGui and /Library/Frameworks/QtGui.framework/Versions/4/QtGui. One of t
he two will be used. Which one is undefined.
Sep 29 03:19:58 macbook [0x0-0xc10c10].net.vidalia-project.vidalia[2562]: objc[2562]: Class QNSPanelProxy is implemented in both /Users/test/src/tbb-master.git/build-script
s/TorBrowser_en-US.app/Contents/MacOS/Vidalia.app/Contents/MacOS/../Frameworks/QtGui.framework/Versions/4/QtGui and /Library/Frameworks/QtGui.framework/Versions/4/QtGui. One of th
e two will be used. Which one is undefined.
Sep 29 03:19:58 macbook [0x0-0xc10c10].net.vidalia-project.vidalia[2562]: objc[2562]: Class QCocoaPageLayoutDelegate is implemented in both /Users/test/src/tbb-master.git/b
uild-scripts/TorBrowser_en-US.app/Contents/MacOS/Vidalia.app/Contents/MacOS/../Frameworks/QtGui.framework/Versions/4/QtGui and /Library/Frameworks/QtGui.framework/Versions/4/QtGui. One of the two will be used. Which one is undefined.
Sep 29 03:19:58 macbook [0x0-0xc10c10].net.vidalia-project.vidalia[2562]: objc[2562]: Class QNSMenu is implemented in both /Users/test/src/tbb-master.git/build-scripts/TorBrowser_en-US.app/Contents/MacOS/Vidalia.app/Contents/MacOS/../Frameworks/QtGui.framework/Versions/4/QtGui and /Library/Frameworks/QtGui.framework/Versions/4/QtGui. One of the two will be used. Which one is undefined.
Sep 29 03:19:58 macbook [0x0-0xc10c10].net.vidalia-project.vidalia[2562]: objc[2562]: Class QNSStatusItem is implemented in both /Users/test/src/tbb-master.git/build-scripts/TorBrowser_en-US.app/Contents/MacOS/Vidalia.app/Contents/MacOS/../Frameworks/QtGui.framework/Versions/4/QtGui and /Library/Frameworks/QtGui.framework/Versions/4/QtGui. One of the two will be used. Which one is undefined.
Sep 29 03:19:58 macbook [0x0-0xc10c10].net.vidalia-project.vidalia[2562]: objc[2562]: Class QNSImageView is implemented in both /Users/test/src/tbb-master.git/build-scripts/TorBrowser_en-US.app/Contents/MacOS/Vidalia.app/Contents/MacOS/../Frameworks/QtGui.framework/Versions/4/QtGui and /Library/Frameworks/QtGui.framework/Versions/4/QtGui. One of the two will be used. Which one is undefined.

Is that something your RelativeLinkOSX.sh can account for, or not so much? I'm going to release the new TBBs tomorrow night BST. If there is a fix, just try to get it to me before then. If not, I'll use the current patch as-is.

comment:6 in reply to:  5 Changed 8 years ago by rransom

Replying to erinn:

This catches almost everything (thanks!), so I'm happy to merge it, but I still get these:

(scary log dump deleted)

Is that something your RelativeLinkOSX.sh can account for, or not so much? I'm going to release the new TBBs tomorrow night BST. If there is a fix, just try to get it to me before then. If not, I'll use the current patch as-is.

I have no clue how to fix that, but it looks like you found the cause of #3935 and #3934.

comment:7 Changed 8 years ago by phobos

I still get one line reported to system.log:
"Oct 18 21:10:31 osxmachine [0x0-0x139e39d].org.torproject.TorBrowserBundle[93231]: Launching Tor Browser Bundle for Linux in /Users/user/Downloads/TorBrowser_en-US.app/"

comment:8 Changed 7 years ago by Sebastian

bug4093 in my repo should fix this

comment:9 in reply to:  8 ; Changed 7 years ago by rransom

Replying to Sebastian:

bug4093 in my repo should fix this

This change should also be applied to the Linux startup script, at least when stdout is not a tty (and thus is probably redirected to $HOME/.xsession-errors). (See 'ARE_WE_RUNNING_IN_A_TERMINAL'.)

comment:10 in reply to:  9 Changed 7 years ago by rransom

Replying to rransom:

Replying to Sebastian:

bug4093 in my repo should fix this

This change should also be applied to the Linux startup script, at least when stdout is not a tty (and thus is probably redirected to $HOME/.xsession-errors). (See 'ARE_WE_RUNNING_IN_A_TERMINAL'.)

On second thought, if 'ARE_WE_RUNNING_IN_A_TERMINAL' gets set to 0, use the shell command "exec >/dev/null 2>&1 " to suppress all output. (Perhaps this would help on MacOS systems with a Qt SDK installed, too.)

comment:11 Changed 7 years ago by Sebastian

Pushed a new branch simply removing all the printfs, tty users who care can just use --debug

comment:12 in reply to:  11 Changed 7 years ago by rransom

Replying to Sebastian:

Pushed a new branch simply removing all the printfs, tty users who care can just use --debug

This doesn't catch messages which pieces of TBB and the system's dynamic loader print to stdout/stderr.

comment:13 Changed 7 years ago by Sebastian

There should be none on stdout, and if there are errors we need at least some way of capturing them... I don't think that at this stage it's wise have no way to get stderr

comment:14 Changed 7 years ago by rransom

See bug4093b ( https://git.torproject.org/user/rransom/torbrowser.git bug4093b ) for a better fix.

comment:15 Changed 7 years ago by Sebastian

Resolution: fixed
Status: needs_reviewclosed

That fix was merged, and a follow-up fix was merged too to fix the bug with debug logs on Linux

comment:16 Changed 18 months ago by teor

Severity: Normal

Set all tickets without a severity to "Normal"

Note: See TracTickets for help on using tickets.