Opened 6 years ago

Closed 6 years ago

#4098 closed defect (fixed)

Arm crashes when TAKEOWNERSHIP command is issued in panel mode

Reported by: Sebastian Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Nyx Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Let me know if more is needed to reproduce:

Traceback (most recent call last):
  File "./src/starter.py", line 543, in <module>
    cli.controller.startTorMonitor(time.time() - initTime)
  File "/Downloads/arm/src/cli/controller.py", line 683, in startTorMonitor
    curses.wrapper(drawTorMonitor, startTime)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/curses/wrapper.py", line 43, in wrapper
    return func(stdscr, *args, **kwds)
  File "/Downloads/arm/src/cli/controller.py", line 784, in drawTorMonitor
    isKeystrokeConsumed = panelImpl.handleKey(key)
  File "/Downloads/arm/src/cli/interpretorPanel.py", line 96, in handleKey
    self.prompt()
  File "/Downloads/arm/src/cli/interpretorPanel.py", line 73, in prompt
    input, isDone = input.strip(), False
AttributeError: 'NoneType' object has no attribute 'strip'

Child Tickets

Change History (1)

comment:1 Changed 6 years ago by atagar

  • Resolution set to fixed
  • Status changed from new to closed

Thanks Sebastian. Reproduced the issue and fixed it:
https://gitweb.torproject.org/arm.git/commitdiff/ed4bee53a3dd4258ced3168819656bff7d8f211f

The problem wasn't related to the input ('TAKEOWNERSHIP arm' works just fine for me). Rather, this was caused by pressing esc which caused a None response that I wasn't expecting.

Cheers! -Damian

Note: See TracTickets for help on using tickets.