Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#4118 closed defect (fixed)

nodelist_assert_ok(): Bug: nodelist.c:397: nodelist_assert_ok: Assertion md->held_by_node == 1 failed

Reported by: ryex Owned by:
Priority: Very High Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version: Tor: 0.2.3.4-alpha
Severity: Keywords: held_by_node tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

[10:32:44] Tor Software Error - The Tor software encountered an internal bug. Please report the following error message to the Tor developers at bugs.torproject.org: "nodelist_assert_ok(): Bug: nodelist.c:397: nodelist_assert_ok: Assertion md->held_by_node == 1 failed; aborting.
"

Child Tickets

Attachments (1)

debug.log (498.6 KB) - added by qbi 8 years ago.
debug.log of this bug

Download all attachments as: .zip

Change History (15)

comment:1 Changed 8 years ago by nickm

Milestone: Tor: 0.2.3.x-final

comment:2 Changed 8 years ago by nickm

Is this with Tor 0.2.3.4-alpha, or some other version?

Changed 8 years ago by qbi

Attachment: debug.log added

debug.log of this bug

comment:3 Changed 8 years ago by qbi

Component: TorStatusTor Client

I can reproduce this bug with every new Tor start.

Tor was working three hours before on this machine. I switched locations and now this error occurs. 

comment:4 Changed 8 years ago by cypherpunks

Keywords: held_by_node added
Version: Tor: 0.2.3.4-alpha

Sep 28 09:47:20.227 [Notice] Tor v0.2.3.4-alpha (git-5f4f727d58daa194). This is experimental software. Do not rely on it for strong anonymity. (Running on Windows 7 Service Pack 1 [workstation])
Sep 28 09:47:20.227 [Notice] Read configuration file "C:\Users\Jared\AppData\Roaming\Vidalia\torrc".
Sep 28 09:47:20.227 [Notice] Initialized libevent version 2.0.14-stable using method win32. Good.
Sep 28 09:47:20.227 [Notice] Opening Socks listener on 127.0.0.1:9050
Sep 28 09:47:20.227 [Notice] Opening Control listener on 127.0.0.1:9051
Sep 28 09:47:20.336 [Notice] Based on 200 circuit times, it looks like we don't need to wait so long for circuits to finish. We will now assume a circuit is too slow to use after waiting 6 seconds.
Sep 28 09:47:20.336 [Notice] Parsing GEOIP file C:\Users\Jared\AppData\Roaming\tor\geoip.
Sep 28 09:47:20.445 [Notice] Configured to measure statistics. Look for the *-stats files that will first be written to the data directory in 24 hours from now.
Sep 28 09:47:21.896 [Notice] OpenSSL OpenSSL 1.0.0e 6 Sep 2011 looks like version 0.9.8m or later; I will try SSL_OP to enable renegotiation
Sep 28 09:47:21.896 [Notice] Reloaded microdescriptor cache. Found 8035 descriptors.
Sep 28 09:47:21.896 [Notice] Removed 2648/8035 microdescriptors as old.
Sep 28 09:47:21.896 [Notice] We now have enough directory information to build circuits.
Sep 28 09:47:21.896 [Notice] Bootstrapped 80%: Connecting to the Tor network.
Sep 28 09:47:21.896 [Notice] New control connection opened.
Sep 28 09:47:22.832 [Notice] Heartbeat: Tor's uptime is 0:00 hours, with 5 circuits open. I've sent 0 kB and received 0 kB.
Sep 28 09:47:22.926 [Notice] Bootstrapped 85%: Finishing handshake with first hop.
Sep 28 09:47:24.392 [Notice] Bootstrapped 90%: Establishing a Tor circuit.
Sep 28 09:47:25.359 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Sep 28 09:47:25.359 [Notice] Bootstrapped 100%: Done.
Sep 28 09:47:26.748 [Error] nodelist_assert_ok(): Bug: nodelist.c:397: nodelist_assert_ok: Assertion md->held_by_node == 1 failed; aborting.

comment:5 Changed 8 years ago by rransom

Priority: majorcritical
10:17 < OFFShare> same bug with a source compiled 0.2.3.4-alpha, an old 0.2.3.2-alpha works fine..

arma reports that moria1 hasn't crashed (yet).

comment:6 Changed 8 years ago by rransom

Summary: Force closenodelist_assert_ok(): Bug: nodelist.c:397: nodelist_assert_ok: Assertion md->held_by_node == 1 failed

comment:7 Changed 8 years ago by nickm

Status: newneeds_review

Possible fix in branch bug4118-hack in my public repo. It turns held_by_node into a refcount.
If it works, I'll clean it up.

comment:8 Changed 8 years ago by nickm

Slightly cleaner version now in branch "bug4118" in my public repository. Please review, test, etc.

comment:9 Changed 8 years ago by sirvaliance

Yeah, I am am also running into this bug:

Sep 28 [err] nodelist_assert_ok(): Bug: nodelist.c:397: nodelist_assert_ok: Assertion md->held_by_node == 1 failed; aborting.
nodelist.c:397 nodelist_assert_ok: Assertion md->held_by_node == 1 failed; aborting.

Been running the latest tor.git/master

comment:10 Changed 8 years ago by nickm

Does my branch "bug4118" in my public repository fix it for you?

comment:11 Changed 8 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

Okay, we've gotten some testing and analysis done; merging the branch to master.

comment:12 Changed 8 years ago by sirvaliance

I pulled and merged the changes from branch "bug4118" and am built and installed on the machine it runs on. It opened a circuit successfully.

comment:13 Changed 7 years ago by nickm

Keywords: tor-client added

comment:14 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.