Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#4119 closed defect (duplicate)

Tor v0.2.3.4-alpha crashes with "nodelist_assert_ok: Assertion md->held_by_node == 1 failed; aborting."

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.3.4-alpha
Severity: Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

After starting tor, it soon crashes with the following in the logs:

Sep 28 19:15:13.000 [notice] Tor 0.2.3.4-alpha (git-9986082fc4414b7d) opening log file.
Sep 28 19:15:13.000 [notice] Based on 1000 circuit times, it looks like we don't need to wait so long for circuits to finish. We will now assume a circuit is too slow to use after waiting 5 seconds.
Sep 28 19:15:13.000 [notice] OpenSSL OpenSSL 0.9.8o 01 Jun 2010 looks like version 0.9.8m or later; I will try SSL_OP to enable renegotiation
Sep 28 19:15:13.000 [notice] Reloaded microdescriptor cache.  Found 11033 descriptors.
Sep 28 19:15:13.000 [notice] Removed 3004/11033 microdescriptors as old.
Sep 28 19:15:13.000 [notice] We now have enough directory information to build circuits.
Sep 28 19:15:13.000 [notice] Bootstrapped 80%: Connecting to the Tor network.
Sep 28 19:15:14.000 [notice] Heartbeat: Tor's uptime is 0:00 hours, with 7 circuits open. I've sent 0 kB and received 0 kB.
Sep 28 19:15:14.000 [notice] Bootstrapped 85%: Finishing handshake with first hop.
Sep 28 19:15:14.000 [notice] Bootstrapped 90%: Establishing a Tor circuit.
Sep 28 19:15:15.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Sep 28 19:15:15.000 [notice] Bootstrapped 100%: Done.
Sep 28 19:15:15.000 [notice] Based on 1000 circuit times, it looks like we need to wait longer for circuits to finish. We will now assume a circuit is too slow to use after waiting 6 seconds.
Sep 28 19:15:17.000 [err] nodelist_assert_ok(): Bug: nodelist.c:397: nodelist_assert_ok: Assertion md->held_by_node == 1 failed; aborting.

The only thing notable is that this is with a running hidden service, if that matters.

Child Tickets

Change History (3)

comment:1 Changed 8 years ago by rransom

Resolution: duplicate
Status: newclosed

Duplicate of #4118.

comment:2 Changed 7 years ago by nickm

Keywords: tor-client added

comment:3 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.