Opened 12 years ago

Last modified 7 years ago

#413 closed defect (Not a bug)

cannot compile svn 9944

Reported by: yancm Owned by:
Priority: High Milestone:
Component: Core Tor/Tor Version: 0.2.0.0-alpha-dev
Severity: Keywords:
Cc: yancm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I try to build svn 9944, I receive the following:

gcc -g -O2 -Wall -g -O2 -L/usr/local/lib -Wl,-R/usr/local/lib -o tor buffers.o circuitbuild.o circuitlist.o circuituse.o command.o config.o connection.o connection_edge.o connection_or.o control.o cpuworker.o directory.o dirserv.o dns.o hibernate.o main.o onion.o policies.o relay.o rendcommon.o rendclient.o rendmid.o rendservice.o rephist.o router.o routerlist.o routerparse.o eventdns.o tor_main.o ../common/libor.a ../common/libor-crypto.a -lz -lpthread -levent -lssl -lcrypto
relay.o(.text+0x2d2e): In function `init_cell_pool':
/home/yancm/torsrc/src/or/relay.c:1488: undefined reference to `mp_pool_new'
relay.o(.text+0x2da4): In function `free_cell_pool':
/home/yancm/torsrc/src/or/relay.c:1496: undefined reference to `mp_pool_destroy'
relay.o(.text+0x2e1e): In function `clean_cell_pool':
/home/yancm/torsrc/src/or/relay.c:1505: undefined reference to `mp_pool_clean'
relay.o(.text+0x2f0e): In function `cell_queue_append_packed_copy':
/home/yancm/torsrc/src/or/relay.c:1519: undefined reference to `mp_pool_get'
relay.o(.text+0x2f4f): In function `cell_queue_clear':
/home/yancm/torsrc/src/or/relay.c:1512: undefined reference to `mp_pool_release'
relay.o(.text+0x3458): In function `connection_or_flush_from_first_active_circuit':
/home/yancm/torsrc/src/or/relay.c:1512: undefined reference to `mp_pool_release'
* Error code 1

Stop.
make: stopped in /home/yancm/torsrc/src/or
* Error code 1

Stop.
make: stopped in /home/yancm/torsrc/src
* Error code 1

Stop.
make: stopped in /home/yancm/torsrc
* Error code 1

Stop.
make: stopped in /home/yancm/torsrc

[1] Exit 1 make

[Automatically added by flyspray2trac: Operating System: BSD]

Child Tickets

Change History (4)

comment:1 Changed 12 years ago by nickm

Looks like you need to re-run autogen.sh, and possibly make clean. Does that fix it?

comment:2 Changed 12 years ago by yancm

Yes. I had run make clean, just forgot to rerun autogen. My mistake.

Clarity is now running svn 9944.

FWIW, 410/411 bugs seem fixed or at least much more stable as of yesterday's svn build. I try to update at lunch (EST/DST) and evenings...just out of habit as much as anything...
--gene

comment:3 Changed 12 years ago by nickm

flyspray2trac: bug closed.

comment:4 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.