Opened 8 years ago

Closed 8 years ago

#4157 closed defect (not a bug)

set browser.urlbar.trimURLs false in torbrowser 2.2.33-2

Reported by: phobos Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: mikeperry, erinn Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The inclusion of Firefox 7.0.1 removes the http:// from the awesome bar. We should set "browser.urlbar.trimURLs" to false to re-enable http:// to be shown for urls.

Child Tickets

Change History (6)

comment:1 Changed 8 years ago by mikeperry

Hrmm.. One would hope that Mozilla actually did usability studies to determine the best way to make it clear to users that they were using a secure connection.

Even if Mozilla didn't do any studies, the Chrome people also settled on the behavior of only displaying the scheme for secure urls.

Surely at least one of them did a study before dropping the scheme from the UI for http urls?

comment:2 Changed 8 years ago by mikeperry

I'll grant that not displaying the scheme might make it more annoying to cut and paste urls and have them be properly hyperlinked in random external software, though. Both Mozilla and Google may have overlooked that property...

In my opinion, too many morons cut and paste urls without explaining what they are anyways. Maybe this change will also slow the spread of malware by making it harder to click on random shit pasted at you?

Or, maybe it will just bias the clickstream in favor of the malware, since malware will be sure to make it as easy as possible to click on shit...

So many tradeoffs. I'm inclined to go with the one that makes it harder for retards to paste unexplained URLs at me, though.

comment:3 Changed 8 years ago by rransom

Cc: mikeperry erinn added
Component: Tor BrowserTor bundles/installation
Owner: changed from mikeperry to erinn

If you select the beginning of a URL in Firefox 7's URL bar, Firefox prepends “http://” to the text it copies to the X selection. (Chromium does that too.)

I'm moving this to the ‘Tor bundles/installation’ because that's where other TBB-Firefox preference tickets are.

comment:4 in reply to:  1 Changed 8 years ago by cypherpunks

Replying to mikeperry:

Hrmm.. One would hope that Mozilla actually did usability studies to determine the best way to make it clear to users that they were using a secure connection.

Even if Mozilla didn't do any studies, the Chrome people also settled on the behavior of only displaying the scheme for secure urls.

Surely at least one of them did a study before dropping the scheme from the UI for http urls?

FireFox 7 does show the https:// for secure urls. It also shows the ftp:// for FTP urls, I think only http:// is hidden. That said, the protocol is formatted in gray, but you can disable that by setting browser.urlbar.formatting.enabled to false.

comment:5 Changed 8 years ago by erinn

Mike, should I be changing this? I can't tell from the comments...

comment:6 Changed 8 years ago by mikeperry

Resolution: not a bug
Status: newclosed

I see no reason to change either pref. I suspect that we're seeing these changes by upstream in an attempt towards URL format harmonization by all of the major browsers, which I assume is guided by usability studies. If these assumptions turn out to be false and the upstream UI is changing wildly for no reason, we can revisit the issue.

Note: See TracTickets for help on using tickets.