Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#4171 closed defect (fixed)

“Tried to establish rendezvous on non-OR or non-edge circuit.”

Reported by: rransom Owned by: rransom
Priority: Medium Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-hs
Cc: twilde@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Seen by an operator of a fairly large relay. The relay was also dropping CREATE cells due to CPU overload.

This message means that there is a bug somewhere. I don't know where.

Child Tickets

Change History (14)

comment:1 Changed 8 years ago by rransom

The relay's operator was not using the relay as a client or hidden service.

comment:2 Changed 8 years ago by tmpname0901

I've seeing this too on 2 relays, one an exit node and the other a middle node.

In both cases the message started on Sept 15th. - the day after I upgraded from 0.2.2.32 to 0.2.2.33.

On the busier node (the exit node) the message has been logged 39 times in the last 19 days.

comment:3 Changed 8 years ago by tmpname0901

Clarification:

I meant that I have seen the message in the title of this bug. If I've been dropping CREATE cells I am unaware of it.

comment:4 Changed 8 years ago by Sebastian

fluxe3 has three to 30 of these in its logs per day. I think we tracked it down and concluded this should be a protocol warning before but then forgot to do anything about it.

comment:5 Changed 8 years ago by rransom

It looks like "non-edge" in that message means that the OR at which the client is trying to ESTABLISH_RENDEZVOUS isn't the last (farthest-from-client) OR on the circuit. At the very least, that part of the message needs to be reworded.

This should become a protocol warning, but we do need to figure out what is going on here if possible.

comment:6 Changed 8 years ago by rransom

Owner: set to rransom
Status: newassigned

comment:7 Changed 8 years ago by nickm

Milestone: Tor: 0.2.3.x-final

Tentatively calling this "tor 0.2.3.x"

comment:8 Changed 8 years ago by twilde

Cc: twilde@… added

comment:9 Changed 8 years ago by rransom

This is caused by #4641.

comment:10 Changed 8 years ago by nickm

#4641 is now fixed in master. Leaving this one open in case we want to downgrade it to protocol_warn.

comment:11 Changed 8 years ago by nickm

Any support for downgrading this message? If not, I suggest we close.

comment:12 Changed 7 years ago by nickm

Resolution: fixed
Status: assignedclosed

Nobody thinks we should downgrade to protocol_warn. Closing.

comment:13 Changed 7 years ago by nickm

Keywords: tor-hs added

comment:14 Changed 7 years ago by nickm

Component: Tor Hidden ServicesTor
Note: See TracTickets for help on using tickets.