Opened 8 years ago

Closed 8 years ago

#4175 closed defect (fixed)

Merge NoScript ChannelReplacement.js

Reported by: mikeperry Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

NoScript has renamed IOUtil.js to ChannelReplacement.js in 2.1.4, and slimmed down the functionality a bit. Giorgio also restricted the use of HTTPS.forceURI() to only apply to TYPE_UNKNOWN and TYPE_OBJECT_SUBOBJECT elements as a mitigation against https://bugzilla.mozilla.org/show_bug.cgi?id=677643.

Once Firefox 8 is released, we should re-enable the content policy and merge in his changes, but we're going to opt to leave it entirely disabled for now.

Child Tickets

Change History (3)

comment:1 Changed 8 years ago by mikeperry

Type: enhancementdefect

Changing this to defect as we're still not sure what the fallout is of us disabling the content policy codepaths, and we don't want to forget about it.

comment:3 Changed 8 years ago by mikeperry

Resolution: fixed
Status: newclosed

Duplicate of #5477.

Note: See TracTickets for help on using tickets.