Opened 8 years ago

Closed 8 years ago

#4182 closed defect (fixed)

Vidalia uses random SOCKS port

Reported by: hellais Owned by: chiiph
Priority: Medium Milestone:
Component: Archived/Vidalia Version:
Severity: Keywords:
Cc: ioerror, arma, alan.hamlett@…, cri@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I believe this was envisioned as a future at the origin, however this makes it much more difficult for the average user to use Tor with, for example, Pidgin.

Also, this + #4181, make setting up Tor with Pidgin a non-trivial task...

Child Tickets

Change History (5)

comment:1 Changed 8 years ago by ahamlett

Cc: alan.hamlett@… added

comment:2 Changed 8 years ago by chiiph

Resolution: fixed
Status: newclosed

You can now properly disable autoconfiguration with Vidalia 0.2.17 and above, and it's disabled by default.

comment:3 Changed 8 years ago by cri

Cc: cri@… added
Resolution: fixed
Status: closedreopened

and it's disabled by default.

This doesn't seem to be the case in the current TBB linux package (2.2.35-8)

With the default configuration, vidalia still uses random ports.

comment:4 in reply to:  3 Changed 8 years ago by arma

Replying to cri:

and it's disabled by default.

This doesn't seem to be the case in the current TBB linux package (2.2.35-8)

With the default configuration, vidalia still uses random ports.

That's correct. See also https://www.torproject.org/docs/faq#TBBSocksPort

For the Tor IM Browser Bundle, is there a good way for Vidalia to tell Pidgin what port it should use?

(I have no idea if this is the right ticket for discussing this. Probably this is a duplicate of something else.)

comment:5 in reply to:  3 Changed 8 years ago by rransom

Resolution: fixed
Status: reopenedclosed

Replying to cri:

and it's disabled by default.

This doesn't seem to be the case in the current TBB linux package (2.2.35-8)

With the default configuration, vidalia still uses random ports.

TBB does not use Vidalia's default configuration. This ticket was about copies of Vidalia shipped separately (e.g. in the Vidalia Bundle).

Note: See TracTickets for help on using tickets.