Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#4217 closed defect (fixed)

Hibernation fix for bug2003 breaks start-as-root, bind-to-low-ports

Reported by: nickm Owned by:
Priority: High Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay
Cc: katmagic Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Zax starts his Tor as root and has it bind to some low ports. When he upgraded to a recent git, he started getting permission denied errors. Git bisect shows that the offending commit was d10ae9c02808c10b19b, which was supposed to ensure that startup worked sanely for hibernating nodes. It looks like that commit makes the bind happen after we drop root.

It's not totally clear to me yet whether this bug only shows up when you're running with accounting. If so, not to worry: that configuration (low ports, start as root, and accounting) isn't something we ever supported, since we can't rebind ports after waking up. But I suspect that the bug shows up either way, with accounting or not. If so, that's a big problem and we should fix it.

Child Tickets

Change History (7)

comment:1 in reply to:  description Changed 8 years ago by rransom

Cc: katmagic added

Replying to nickm:

It's not totally clear to me yet whether this bug only shows up when you're running with accounting. If so, not to worry: that configuration (low ports, start as root, and accounting) isn't something we ever supported, since we can't rebind ports after waking up. But I suspect that the bug shows up either way, with accounting or not. If so, that's a big problem and we should fix it.

This bug bit katmagic today, with DNSPort 53 and no accounting or relay options set.

comment:2 Changed 8 years ago by Sebastian

Status: newneeds_review

Yeah, I just reproduced this. Tested fix in branch bug4217 in my repository.

comment:3 Changed 8 years ago by nickm

Looks good. Merging, and making a note on #2003.

comment:4 Changed 8 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

comment:5 Changed 8 years ago by Sebastian

This worked ok, but broke the #2003 fix. I'm leaving this ticket closed, because #2003 is where the real work needs to be done.

comment:6 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:7 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.