Opened 7 years ago

Closed 9 months ago

#4235 closed defect (wontfix)

Vidalia doesn't exit when Firefox exits on Mac OSX

Reported by: mikeperry Owned by: chiiph
Priority: Medium Milestone:
Component: Archived/Vidalia Version:
Severity: Normal Keywords: archived-closed-2018-07-04
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I've noticed that when Firefox exits on the Mac, Vidalia doesn't shut down and kill Tor. This can cause confusion for people when they try to start TBB again to get the browser back.

Child Tickets

Change History (8)

comment:1 Changed 7 years ago by tmpname0901

I see the same thing on Linux (Fedora 13/x86_64).

comment:2 Changed 7 years ago by keb

Component: VidaliaTor Browser
Keywords: tbb added
Owner: changed from chiiph to mikeperry

me too
lubuntu 11.04
TBB 2.2.34-1

comment:3 Changed 7 years ago by keb

Component: Tor BrowserTor bundles/installation
Owner: changed from mikeperry to erinn

comment:4 Changed 7 years ago by mikeperry

Component: Tor bundles/installationVidalia
Keywords: tbb removed
Owner: changed from erinn to chiiph
Status: newassigned

keb: This is a Vidalia bug. The problem is rooted in how Vidalia tracks the Firefox child process on Mac OS, which it launches. Reassigning it to me and/or Erinn will just cause the issue to get lost and forgotten.

comment:5 Changed 7 years ago by erinn

Should it? We can make it, but some people want to close the browser and keep Vidalia running. It's even on our FAQ: https://www.torproject.org/docs/faq.html.en#TBBCloseBrowser

I guess we want it to, on all platforms, but if that is the case then we should have a different answer for that FAQ.

Reassigning to chiiph since this is actually something that has to be fixed in Vidalia.

comment:6 in reply to:  5 Changed 7 years ago by mikeperry

Replying to erinn:

Should it? We can make it, but some people want to close the browser and keep Vidalia running. It's even on our FAQ: https://www.torproject.org/docs/faq.html.en#TBBCloseBrowser

I guess we want it to, on all platforms, but if that is the case then we should have a different answer for that FAQ.

Wow, yeah, I think we're letting the inmates run the asylum by catering to that FAQ entry. Have we actually been trying to support that? See also #4258 and #4262 for similar issues on Linux (which are more recent than this issue).

I've watched my Mac friends puzzle over why they can't easily relaunch TBB after exiting the browser but leaving Vidalia open. Most of them get confused by the extra Vidalia dock icon in other scenarios too.. The whole user experience on Mac OSX is probably bad enough to cause Steve Jobs to rise from the grave and ban our app from the app store :(.

Fear the Zombie Steve Jobs.

comment:7 Changed 16 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:8 Changed 9 months ago by teor

Keywords: archived-closed-2018-07-04 added
Resolution: wontfix
Status: assignedclosed

Close all tickets in archived components

Note: See TracTickets for help on using tickets.