Opened 6 years ago

Closed 6 years ago

#4237 closed defect (fixed)

arm warning when used with tor master

Reported by: Sebastian Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Nyx Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

when used with current master, arm prints this warning:

[ARM_WARN] The torrc differ from what tor's using. You can issue a sighup to reload the torrc values by pressing x.
   - configuration value is missing from the torrc: DirReqStat
}}}}

Also there's a typo here, it should be "The torrc differS from what" I think.

Child Tickets

Change History (3)

comment:1 Changed 6 years ago by atagar

  • Status changed from new to needs_information

Thanks, though neither I nor Kamran are having luck reproducing this. I'm using tor 0a083b0 - are you sure that your tor instance was using your current torrc?

Also there's a typo here, it should be "The torrc differS from what" I think.

Yup, fixed:
https://gitweb.torproject.org/arm.git/commitdiff/38af67c1dbe9e06d0375811b0df1afaa0bffd4a7

comment:2 Changed 6 years ago by atagar

  • Status changed from needs_information to accepted

Sebastian found the cause. New versions of tor default DirReqStatistics to being true, and if the geoip is unavailable then this is changed...

if (geoip_is_loaded()) {
  geoip_dirreq_stats_init(now);
  print_notice = 1;
} else {
  options->DirReqStatistics = 0;

On reflection the issue for arm is that I'm making the assumption that tor uses the configurations the user gives, and if it differs then they should be alerted. This is the first time (that I'm aware of) that tor alters its own config so if you start tor with torrc X, then issue a SAVECONF right away, the saved torrc will functionally differ from X.

Adding an exemption for this option to the warning.

comment:3 Changed 6 years ago by atagar

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.