Opened 8 years ago

Closed 7 years ago

#4238 closed enhancement (duplicate)

Torbutton should pass TBB's OS and architecture to www.tpo download pages

Reported by: rransom Owned by: mikeperry
Priority: Medium Milestone:
Component: TorBrowserButton Version:
Severity: Keywords:
Cc: phobos, mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Torbutton should pass TBB's operating system and architecture (not the OS and architecture that it's running on; e.g. TBB for 32-bit Linux run on FreeBSD-AMD64 should pass “Linux” and “i686”) to JavaScript running on www.tpo/download/download-easy and www.tpo/download/download. This should probably be done by adding a ‘fragment identifier’ (e.g. ...#foozer) to the URL when browsing to those URLs without a fragment identifier.

Ideally, the fragment identifier would still point users to the correct section of the page even when JavaScript is disabled.

Child Tickets

Change History (8)

comment:1 Changed 8 years ago by mikeperry

Do we support this already on the download-easy page? If so, what fragment names do I need to I use?

It looks like there is some code that is trying to allow platform selection, but the names it is checking for don't seem to work as fragments.

comment:2 Changed 8 years ago by phobos

Would it be easier to simply add 32-bit/64-bit to the download button?

comment:3 in reply to:  2 Changed 8 years ago by rransom

Replying to phobos:

Would it be easier to simply add 32-bit/64-bit to the download button?

We need to do that anyway for users who don't have TBB yet and use an OS where the 32-bit/64-bit distinction matters. That is not a substitute for offering users a package for the correct OS (which is not necessarily Windows).

comment:4 Changed 8 years ago by mikeperry

Component: TorbuttonTorBrowserButton

comment:5 Changed 7 years ago by mikeperry

Keywords: tbb-usability tbb-bounty added

comment:6 Changed 7 years ago by mcs

Cc: mcs brade added

Would it be sufficient to add "os" and "arch" parameters to the startup page, e.g.,

https://check.torproject.org/?lang=en-US&os=Linux&arch=i686&small=1&uptodate=0

?

The server / web site would need to be modified to propagate those values to the download page, but this seems like a simpler solution than having the browser look at every page load to determine if the os and arch should be added to the URL.

comment:7 Changed 7 years ago by mikeperry

Hrmm, this might not be a terrible idea. I guess the plan is to only transmit these values to check for the out of date message. The download link could then be written by check to include these values. However, in #6096, we want to try to do away with the check-based notification entirely I think. As part of that, we can have *that* UI pass the right OS+arch info to the download page.

We should probably merge this ticket, #6156, and #6096 into a single, sane plan in a fresh ticket.

comment:8 Changed 7 years ago by mikeperry

Keywords: tbb-usability tbb-bounty removed
Resolution: duplicate
Status: newclosed

Ok. I've filed #7495 for moving check's update notification into the browser, which should allow us to have the browser pass the OS+arch in the download link without either request observers or modifying check itself. Calling this a duplicate of #7495.

Note: See TracTickets for help on using tickets.