Opened 8 years ago

Closed 2 years ago

Last modified 2 years ago

#4272 closed defect (duplicate)

choose_url throws confusing exception in bw auth

Reported by: mikeperry Owned by: mikeperry
Priority: Medium Milestone:
Component: Core Tor/Torflow Version:
Severity: Normal Keywords:
Cc: karsten, aagbsn, mikeperry Actual Points:
Parent ID: #17064 Points:
Reviewer: Sponsor:

Description

Karsten noted that choose_url throws a confusingly-worded exception. It currently throws a selection error saying no nodes remain, but what it really means is you passed it a percentile above 100.

Child Tickets

Change History (5)

comment:1 Changed 5 years ago by arma

So the fix should be to reword the string?

comment:2 Changed 5 years ago by aagbsn

Related to #4269

comment:3 Changed 2 years ago by teor

Resolution: duplicate
Severity: Blocker
Status: newclosed

I think this is a duplicate of one of the children of #24094.

comment:4 Changed 2 years ago by teor

Severity: BlockerNormal

comment:5 Changed 2 years ago by teor

Parent ID: #17064

Actually, that was #17064

Note: See TracTickets for help on using tickets.