Opened 8 years ago

Closed 8 years ago

#4328 closed defect (duplicate)

NoScript's video blocking breaks Youtube html5

Reported by: phobos Owned by: mikeperry
Priority: Medium Milestone:
Component: Firefox Patch Issues Version:
Severity: Keywords:
Cc: the.magical.kat@…, g.koppen@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Using the latest tbb (0.2.2.33-3) for osx and linux on youtube, opt-in to the html5 video test, try to browse for html5 videos on youtube. Either none exist, or tbb html5 video support doesn't work.

Try this on vimeo, which automatically swaps between flash and html5 if the browser identification string implies support. Always get the flash video 'install flash'. message.

The only place I can get html5 video to work is on tor's own website.

Child Tickets

Change History (10)

comment:1 Changed 8 years ago by phobos

For added fun, I opted youtube.com/thetorproject into html5 conversion. Should work fine (does work in firefox 7.0.1 native (not TBB).

comment:2 Changed 8 years ago by mikeperry

I seem to still be able to view select videos on youtube in html5 in my TBB. https://www.youtube.com/watch?v=8LsxmQV8AXk works after opting in for example.

The vimeo thing could be due to our Firefox 5.0 uagent string. I've been meaning to update that, but have been waiting for a release where we don't have also security issue (to avoid explicitly partitioning the vulnerable users).

comment:3 Changed 8 years ago by mikeperry

If I go to Tor videos direcly, I can watch some of them. The bridge one works, for example: https://www.youtube.com/watch?v=n0JSPcyCjCk

comment:4 Changed 8 years ago by runa

I have joined the HTML5 trial, but the two links you provided aren't working. I'm currently using TBB 64 bit, 2.2.33-dev.

comment:5 Changed 8 years ago by phobos

On stock tbb 0.2.2.34-1 (released tonight) for 64-bit linux;

  1. I hit https://www.youtube.com/html5. I join the html5 trial.
  2. I hit https://www.youtube.com/watch?v=8LsxmQV8AXk and it tells me to "Upgrade to Flash Player 10 for improved playback performance. Upgrade Now or More Info."

comment:6 Changed 8 years ago by mikeperry

Are you both using 64bit only? I just tested OSX 32bit and it works fine, too. Sounds like a codec issue w/ 64bit builds?

comment:7 Changed 8 years ago by mikeperry

Cc: the.magical.kat@… added

Alternatively, it could be exit node issues? katmagic seemed to have issues with youtube forgetting the html5 opt-in periodically when testing out solutions for #3347.

comment:8 Changed 8 years ago by gk

Cc: g.koppen@… added

comment:9 Changed 8 years ago by mikeperry

I just noticed that there is a NoScript issue with remote-sourced HTML5 video in my TBB. The NoScript placeholders for ogg/video content seem to conflict with the youtube js. Going into my NoScript settings and unchecking "Forbid AUDIO / VIDEO" in the embeddings tab makes third-party html5 youtube work for me. Strangely, this setting does not cause problems when I click-to-play html5 youtube videos on youtube itself, though. So possibly a separate issue?

comment:10 Changed 8 years ago by mikeperry

Resolution: duplicate
Status: newclosed
Summary: youtube/vimeo html5 video doesn't work in tor browser bundleNoScript's video blocking breaks Youtube html5

I think the main remaining issue is #5266. Dupping this issue to that one.

Note: See TracTickets for help on using tickets.