Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#4332 closed defect (duplicate)

Bootstrap appears to be hung when starting in hibernation

Reported by: tmpname0901 Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Version 0.2.2.34.

It appears that the bootstrap process got stuck when it noticed that I had reach my specified monthly bandwidth limit. It's been at 85% for about a half-hour now.

Oct 27 23:19:49.213 [notice] We now have enough directory information to build circuits.
Oct 27 23:19:49.213 [notice] Bootstrapped 80%: Connecting to the Tor network.
Oct 27 23:19:50.251 [notice] Bandwidth soft limit reached; commencing hibernation. No new conncetions will be accepted
Oct 27 23:19:50.251 [notice] Going dormant. Blowing away remaining connections.
Oct 27 23:19:50.478 [notice] Bootstrapped 85%: Finishing handshake with first hop.

Child Tickets

Change History (3)

comment:1 Changed 8 years ago by Sebastian

Resolution: duplicate
Status: newclosed

This is a semi-duplicate of #2003. The correct behaviour would be not to bootstrap at all, and instead start hibernating right at the beginning. So, "getting stuck" like this just means we realized we should've been hibernating all along, and stop doing anything.

comment:2 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:3 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.