Opened 8 years ago

Closed 7 years ago

#4346 closed defect (fixed)

Unable to open "cached-descriptors.new" sometimes

Reported by: bastik Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: 0.2.3.6-alpha
Severity: Keywords: windows tor-relay
Cc: bastik.public@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Somtimes Tor can't open C:\Users\[username]\AppData\Roaming\tor\cached-descriptors.new and therefore warns about it.

It turns out to be a conflict on accessing the file due to multiple processes reading that file.

It worked with 0.2.2.x builds, with the same software accessing the file. There where no problems.

I have attached a "details.zip" You should note that is was not that reproducible before. Before I looked into it I launched Vidalia and sometimes the warning occurred and sometimes not. (Same software same settings)

I launch Vidalia/Tor once a day (at least under normal conditions) and so I did for testing.

Child Tickets

Attachments (1)

details.zip (943.7 KB) - added by bastik 8 years ago.
logs and "problem.txt"

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by bastik

Attachment: details.zip added

logs and "problem.txt"

comment:1 Changed 8 years ago by nickm

What else is it that's reading the file at the same time?

comment:2 in reply to:  1 Changed 8 years ago by bastik

Cc: bastik.public@… added

Replying to nickm:

What else is it that's reading the file at the same time?

Firewall behavior analysis (that's included in the details.zip)

Recently I added Mircosoft Security Essensials (MSE) to my system. (see details.zip)
So MSE accessed the file, too. (details)

For testing purpose the behavior analysis is disabled. Only MSE and Tor access the file. So far no errors. Interestingly this error did not show up earlier since the behavior analysis was there before Tor was installed and after I installed Tor both worked just fine... at least there were no errors. (Just after I updated Tor)

At the time of writing I'd like to figure out if it's just the behavior analysis that would cause that or if anything (like MSE, which was installed after the Tor update) could make that happen.

comment:3 Changed 8 years ago by nickm

Keywords: windows added
Milestone: Tor: 0.2.3.x-final

This is a regular windows problem, but I don't know the solution. Previously we had thought that the answer might involve opening files nonexclusively, or marking them as not-to-be-examined by other tools. More investigation needed! I'd like to try to come up with an answer for 0.2.3.x if we can.

comment:4 Changed 8 years ago by nickm

Milestone: Tor: 0.2.3.x-finalTor: unspecified
Status: newneeds_information

comment:5 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:6 Changed 7 years ago by nickm

Component: Tor RelayTor

comment:7 Changed 7 years ago by bastik

The warning disappeared in the 0.2.3 branch and never appeared in the 0.2.4 branch. I can't remember when I saw it.

I updated Tor a lot, the operating system and other software changed since then as well.

Can we close this?

comment:8 Changed 7 years ago by nickm

Resolution: fixed
Status: needs_informationclosed

Sure; seems plausible.

Note: See TracTickets for help on using tickets.