Opened 8 years ago

Closed 8 years ago

#4356 closed defect (fixed)

tbb on osx 10.4.11 should give a more useful "i'm not compatible" message

Reported by: arma Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

https://blog.torproject.org/blog/new-tor-browser-bundles-4#comment-12421 is an example of a user trying TBB on 10.4.11.

Erinn saw it and said TBB "shouldn't run on 10.4 anyway".

If that is so,

A) Do we have plans to fix TBB so it runs on 10.4?

B) If not, we should make it produce a more useful error message. Something like detecting the OS X version and explaining that we're sorry but they'll need to use the Vidalia bundle.

Child Tickets

Change History (3)

comment:1 Changed 8 years ago by erinn

A) No. Firefox dropped support for 10.4.

B) I agree with this, although I wouldn't expect TBB/Vidalia to even launch on 10.4, much less give that specific error message, so I'd like to get more information from the user. In the past we got weird bus errors when things weren't built with sufficient backwards compatibility (but maybe this was only for PPC?)

In any case, detecting the version in the launch script should be possible. I'm not sure offhand how to send the incompatibility information to users, but that seems like something that has been done before.

comment:2 Changed 8 years ago by Sebastian

Status: newneeds_review

bug4356 in my repo has a suggested fix

comment:3 Changed 8 years ago by erinn

Resolution: fixed
Status: needs_reviewclosed

Merged bug4356, this is in the most recent tbb. Closing.

Note: See TracTickets for help on using tickets.