Opened 8 years ago

Closed 8 years ago

#4376 closed defect (duplicate)

Tor crashes about 5 times per hour since version 0.2.2.34

Reported by: nlmarco Owned by: ioerror
Priority: Medium Milestone:
Component: Archived/Torouter Version: Tor: 0.2.2.34
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I run a TOR exit node (inside a chroot jail) for years already and all previous versions were quite stable. But since I updated to 0.2.2.34 a few days ago, my TOR daemon silently disappears pretty often.

I wrote a watchdog shell script that automatically restarts Tor, if it crashed. Cron runs this script every minute. The result is that Tor is now started approximately 4 to 7 times per hour.

I don't know, yet, what's going on, because I deactivated logging completely, but if you need more information (and are not yet aware of the problem), I'd be able to enable logging.

Here my environment:

Kernel: 2.6.32-34-server #77-Ubuntu SMP Tue Sep 13 20:54:38 UTC 2011 x86_64 GNU/Linux

libevent: 1.4.13-stable-1

I compiled Tor from sources (not using any of the precompiled packages).

Child Tickets

Change History (1)

comment:1 Changed 8 years ago by Sebastian

Resolution: duplicate
Status: newclosed

This is a duplicate of #4340. In short, configure Tor to use the geoipfile configuration option to point to the geoip file (it is in the source distribution in the src/config/ directory, name geoip); wait for the next release of 0.2.2.x (could be a while), use 0.2.3.7-alpha for now, or fetch the current maint-0.2.2 branch and build that.

Note: See TracTickets for help on using tickets.