Opened 8 years ago

Closed 6 years ago

#4393 closed defect (duplicate)

"New identity" closes all open tabs without warning/prompt

Reported by: cypherpunks Owned by: mikeperry
Priority: Medium Milestone: TorBrowserBundle 2.3.x-stable
Component: TorBrowserButton Version:
Severity: Keywords: tbb-usability, tbb-newnym
Cc: proper@…, arma, mrphs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I was browsing with several tabs open when I thought I'd use the new identity feature of Torbutton. I clicked on green onion symbole in Aurora and then on "New Identity". To my horror all tabs and browser windows vanished and I was presented with a empty browser window.

This was unexpected and very unpleasant. I used the "Use a new identity" button in Vidalia previously and nothing like that ever happened. I expected all NEW connections to be different but no action happening to my current browsing.

Please add a prompt (like "All tabs will be closed") to that feature to save people's browsing.

Child Tickets

Change History (7)

comment:1 Changed 8 years ago by mikeperry

Component: TorbuttonTorBrowserButton

comment:2 Changed 8 years ago by mikeperry

Milestone: TorBrowserBundle 2.3.x-stable

comment:3 Changed 8 years ago by mikeperry

#3944 technically blocks this, since any checkbox-prompt preference value will keep getting reset on upgrade, making this very annoying.

comment:4 Changed 7 years ago by proper

Cc: proper@… added

It's a good idea to educate the users about it.

The "All tabs will be closed" prompt should contain a checkbox "don't tell me again".

comment:5 Changed 7 years ago by mikeperry

Keywords: tbb-usability added; identity tabs window aurora tbb removed
Summary: "New identity" closes all open tabs in Torbundle without warning/prompt"New identity" closes all open tabs without warning/prompt

comment:6 Changed 7 years ago by arma

Cc: arma mrphs added

comment:7 Changed 6 years ago by arma

Keywords: tbb-newnym added
Resolution: duplicate
Status: newclosed

I'm going to call this one a duplicate of #9906. Man we have a lot of overlapping tickets on this topic.

See also https://trac.torproject.org/projects/tor/query?status=!closed&keywords=~tbb-newnym

Note: See TracTickets for help on using tickets.