Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#4435 closed defect (fixed)

Trac no longer allows child tickets of ‘defect’s.

Reported by: rransom Owned by: erinn
Priority: High Milestone:
Component: Internal Services/Service - trac Version:
Severity: Keywords:
Cc: karsten, Sebastian Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Child Tickets

Change History (7)

comment:1 Changed 8 years ago by nickm

This one is seriously interfering with my ability to get work done. The failure mode is that it is impossible to edit a child ticket without first changing the parent ticket's type to "project", which is a distraction.

Instructions for enabling child tickets for given ticket types are here:
http://trac-hacks.org/wiki/ChildTicketsPlugin

Can somebody who is allowed to edit trac.ini please configure it so that every ticket type is allowed to have child tickets?

comment:2 Changed 8 years ago by erinn

Resolution: fixed
Status: newclosed

This should be fixed now. If you see any areas where it is still broken, please reopen.

comment:3 Changed 8 years ago by nickm

Closed #4384 as a duplicate of this.

comment:4 Changed 8 years ago by nickm

Resolution: fixed
Status: closedreopened

Could you please do the necessary voodoo for "enhancement" tickets too? I tried to poke #2693 and got:

Warning: The parent ticket (#2664) has type enhancement which does not allow child type 'enhancement'. Must be one of : defect,task,project. 

comment:5 Changed 8 years ago by weasel

Status: reopenedneeds_review

Different, but related issue. It might be fixed now, please confirm.

(commented out "parent.enhancement.restrict_child_type = defect, task, project").

comment:6 Changed 8 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

Seems to be better now; thank you, weasel!

comment:7 Changed 4 years ago by qbi

Component: TracService - trac

Move all tickets from trac to "Service - trac" component.

Note: See TracTickets for help on using tickets.