Opened 8 years ago

Closed 20 months ago

#4453 closed defect (worksforme)

Torbutton always reset SOCKS port to 9050

Reported by: lunar Owned by:
Priority: Medium Milestone:
Component: Applications/Torbutton Version: Torbutton: 1.4.4
Severity: Normal Keywords:
Cc: lunar@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Wherever Torbutton is set to use recommended settings or not, the SOCKS port is always reset to 9050, or the value of the environment variable TOR_SOCKS_PORT. The same issue affects the SOCKS host.

Child Tickets

Attachments (2)

0001-Bug-4453-Set-SOCKS-port-and-host-only-with-recommend.patch (1.7 KB) - added by lunar 8 years ago.
Possible fix against current master (7c94dc6f635)
0001-Bug-4453-Set-SOCKS-port-and-host-only-with-recommend_v2.patch (1.4 KB) - added by lunar 8 years ago.

Download all attachments as: .zip

Change History (12)

Changed 8 years ago by lunar

Possible fix against current master (7c94dc6f635)

comment:1 Changed 8 years ago by lunar

Status: newneeds_review

comment:2 Changed 8 years ago by mikeperry

Owner: changed from mikeperry to lunar
Status: needs_reviewassigned

Did you test this in both TBB and Iceweasel? I suspect if you tested it in TBB, it will break after you open a 2nd new window, because it will reset the SOCKS port to 9050.

The problem is that the TOR_SOCKS_PORT is not used in torbutton_init_prefs().. torbutton_init_prefs() is called on every new window (yes, this is somewhat dumb, but it is a relic of old code).

comment:3 Changed 8 years ago by lunar

I had not tested it with TBB. My bad.

Here comes another version. Looks like it works for both now…

comment:4 Changed 8 years ago by lunar

Status: assignedneeds_review

comment:5 Changed 8 years ago by mikeperry

Resolution: fixed
Status: needs_reviewclosed

Merged. Thanks!

comment:6 Changed 7 years ago by unknown

Resolution: fixed
Status: closedreopened

After experimenting with using TorBrowser connected to Linux system tor-daemon running with multiple SOCKSports options, I found the problem. Despite SOCKSport is changed in TorButton to any value, TorBrowser connects to Tor only through 9050. I check it with Wireshark/Iptables.

Attempts to change values in files does not help too:

App/Firefox/defaults/profile/prefs.js:user_pref("extensions.torbutton.socks_port",9050);

App/Firefox/defaults/profile/prefs.js:user_pref("network.proxy.socks_port",9050);
Data/profile/prefs.js:user_pref("extensions.torbutton.custom.socks_port", 9050);
Data/profile/prefs.js:user_pref("extensions.torbutton.socks_port", 9050);
Data/profile/prefs.js:user_pref("network.proxy.socks_port", 9050);

Is it possible to connect to non-9050 system Tor ?

Running TorBrowsers simultaneously divided by the means of iptables in parallell X-sessions fails. All TorBrowsers wants to works with localhost only through 9050 in the case non-TBB (system) tor.

"Transparent Torification" option in TorButton without local proxy doesn't works too.

TorButton 1.4.6 / tor-browser-gnu-linux-x86_64-2.2.37-1-dev-en-US.

comment:7 Changed 7 years ago by lunar

Owner: lunar deleted
Status: reopenedassigned

comment:8 Changed 2 years ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:9 Changed 2 years ago by teor

Status: assignednew

Mark all tickets that are assigned to nobody as "new".

comment:10 Changed 20 months ago by gk

Resolution: worksforme
Status: newclosed

I think this works now with Torbutton and TorLauncher.

Note: See TracTickets for help on using tickets.