Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4478 closed defect (duplicate)

Firefox 8.0 Homepage not getting rewritten to HTTPS

Reported by: pgkool Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

My homepage in firefox is set to "www.google.com", while in older firefox builds this would automatically get rewritten to https, in the new 8.0 build, the homepage will come up as the unencrypted flavor.

Hitting the home button shows the HTTPS version. Also doing a search from his page redirects to HTTPS, but on initial Firefox Launch, the home page is HTTP (not secure). Also when taking advantage of Google's Instant search results, this too will go to the HTTP (non secure) version of the page.

Child Tickets

Change History (5)

comment:1 Changed 8 years ago by pgkool

while playing around with this bug more, it has been noticed that this is caused by the prefrences setting for the homepage.

My homepage is set to "http://www.google.com" and this causes firefox to open up with the HTTP (non secure) version while if my homepage is set as "www.google.com" it works fine and rewrites to HTTPS.

comment:2 Changed 8 years ago by pde

This sounds like it is probably a duplicate of bug #3533, which is fixed in the development branch releases (eg https://www.eff.org/files/https-everywhere-2.0development.4.xpi), but not in stable releases yet.

comment:3 Changed 8 years ago by pde

Resolution: duplicate
Status: newclosed

(I'm going to mark this a closed for now, please reopen if you can reproduce it while running development branch of HTTPS Everywhere)

comment:4 Changed 8 years ago by pgkool

Fixed in build HTTPS Everywhere 1.2.1. Thankyou.

comment:5 in reply to:  4 Changed 8 years ago by pgkool

Replying to pgkool:

Fixed in build HTTPS Everywhere 1.2.1. Thankyou.

ERRR I ment build 2.0 dev 4

Note: See TracTickets for help on using tickets.