Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#4481 closed defect (fixed)

Couldn't send netinfo cell

Reported by: stars Owned by:
Priority: Medium Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi to everyone,

From today after having upgraded my Tor relay to the last git, i get non stop a message that say : Couldn't send netinfo cell

nov. 16 12:34:39.326 [Notice] Tor v0.2.3.7-alpha (git-c4a4ac7de6d32482) (with bufferevents). This is experimental software. Do not rely on it for strong anonymity. (Running on Linux x86_64)
nov. 16 12:34:39.327 [Notice] Read configuration file "/home/xxxxxx/SwissTorHelp/torrc".
nov. 16 12:34:39.327 [Notice] Initialized libevent version 2.1.0-alpha-dev using method epoll (with changelist). Good.
nov. 16 12:34:39.327 [Notice] Opening OR listener on 0.0.0.0:9090
nov. 16 12:34:39.327 [Notice] Opening Directory listener on 0.0.0.0:9091
nov. 16 12:34:39.327 [Notice] Opening Socks listener on xxxxxxx
nov. 16 12:34:39.327 [Notice] Opening Socks listener on xxxxxx
nov. 16 12:34:39.327 [Notice] Socks listener listening on port xxxx.
nov. 16 12:34:39.328 [Notice] Opening DNS listener on xxxxxxxxx
nov. 16 12:34:39.328 [Notice] Opening Control listener on xxxxxxx
nov. 16 12:34:39.328 [Notice] Control listener listening on port xxxx.
nov. 16 12:34:39.328 [Notice] Parsing GEOIP file /xxxxxxxxxxxx/tor/src/config/geoip.
nov. 16 12:34:43.213 [Notice] Configured to measure statistics. Look for the *-stats files that will first be written to the data directory in 24 hours from now.
nov. 16 12:34:43.213 [Notice] OpenSSL OpenSSL 1.0.0e 6 Sep 2011 looks like version 0.9.8m or later; I will try SSL_OP to enable renegotiation
nov. 16 12:34:43.214 [Notice] Your Tor server's identity key fingerprint is 'SwissTorHelp xxxxxxxxxxxxxxxxxxx
nov. 16 12:34:43.214 [Notice] Reloaded microdescriptor cache. Found 9163 descriptors.
nov. 16 12:34:43.214 [Notice] Removed 2745/9163 microdescriptors as old.
nov. 16 12:34:43.214 [Notice] We now have enough directory information to build circuits.
nov. 16 12:34:43.214 [Notice] Bootstrapped 80%: Connecting to the Tor network.
nov. 16 12:34:43.214 [Notice] New control connection opened.
nov. 16 12:34:43.214 [Notice] Guessed our IP address as xxxxxxx (source: 194.109.206.212).
nov. 16 12:34:44.000 [Notice] Heartbeat: Tor's uptime is 0:00 hours, with 1 circuits open. I've sent 6 kB and received 2 kB.
nov. 16 12:34:44.149 [Notice] Bootstrapped 85%: Finishing handshake with first hop.
nov. 16 12:34:44.421 [Notice] Self-testing indicates your ORPort is reachable from the outside. Excellent. Publishing server descriptor.
nov. 16 12:34:45.194 [Notice] Bootstrapped 90%: Establishing a Tor circuit.
nov. 16 12:34:46.988 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
nov. 16 12:34:46.989 [Notice] Bootstrapped 100%: Done.
nov. 16 12:34:47.138 [Warning] Couldn't send netinfo cell
nov. 16 12:35:21.863 [Warning] Couldn't send netinfo cell
nov. 16 12:35:45.142 [Warning] Couldn't send netinfo cell
nov. 16 12:35:45.444 [Warning] Couldn't send netinfo cell
nov. 16 12:35:46.630 [Notice] Self-testing indicates your DirPort is reachable from the outside. Excellent.
nov. 16 12:35:51.422 [Warning] Couldn't send netinfo cell
nov. 16 12:36:08.053 [Warning] Couldn't send netinfo cell
nov. 16 12:36:10.197 [Warning] Couldn't send netinfo cell
nov. 16 12:36:13.063 [Warning] Couldn't send netinfo cell
nov. 16 12:36:13.307 [Warning] Couldn't send netinfo cell
nov. 16 12:36:43.269 [Warning] Couldn't send netinfo cell
nov. 16 12:37:09.930 [Warning] Couldn't send netinfo cell
nov. 16 12:37:44.432 [Warning] Couldn't send netinfo cell
nov. 16 12:37:55.106 [Notice] Performing bandwidth self-test...done.
nov. 16 12:37:56.107 [Warning] Couldn't send netinfo cell

Child Tickets

Change History (9)

comment:1 Changed 8 years ago by Sebastian

Milestone: Tor: 0.2.2.x-final
Priority: normalmajor
Version: Tor: 0.2.3.7-alphaTor: unspecified

Hrm. This was caused by the #4349 fix, which is also in maint-0.2.2 now. Ugh.

   /* Their address. */
   out = cell.payload + 4;
-  len = append_address_to_payload(out, &conn->_base.addr);
+  len = append_address_to_payload(out, &conn->real_addr);
   if (len<0)
     return -1;
   out += len;

What happens is that &conn->real_addr is NULL, so append_address_to_payload() returns -1.

comment:2 Changed 8 years ago by Sebastian

and with NULL I mean empty struct. Bad Sebastian doing his debugging wrong. Thanks frosty_un for pointing this out, and also pointing out that we call connection_or_init_conn_from_address() later if we have a V3 handshake.

comment:3 Changed 8 years ago by Sebastian

I have an idea for a fix in branch bug4481 in my repository. We should also check out the other uses of real_addr, to make sure we don't accidentally use it while it isn't initialized. From a glance at the code this may well happen.

I think this also means we're fine in 0.2.2.x, because we don't use the V3 handshake there. So the branch is on master. But it's not ready for merge anyway.

comment:4 Changed 8 years ago by Sebastian

After an hour of testing current 0.2.2.x and patched master with my bug4481 branch, the messages don't show up.

comment:5 Changed 8 years ago by Sebastian

Milestone: Tor: 0.2.2.x-finalTor: 0.2.3.x-final
Priority: majornormal

comment:6 Changed 8 years ago by Sebastian

Status: newneeds_review

Branch ready for review&merge

comment:7 Changed 8 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

Merged

comment:8 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:9 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.