Opened 8 years ago

Closed 8 years ago

#4493 closed defect (fixed)

Error: found duplicate rule name GoogleMaps

Reported by: gk Owned by: pde
Priority: Low Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: stars@…, carenas@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

HTTPS Everywhere: Error: found duplicate rule name GoogleMaps in file /~/extensions/https-everywhere@…/chrome/content/rules/GoogleMaps.xml~HEAD

in HTTPS-Everywhere 1.2.1.

Child Tickets

Attachments (2)

default.rulesets (351.3 KB) - added by stars 8 years ago.
/.mozilla/firefox/avjs7hib.default/extensions/https-everywhere@…/chrome/content/rules
default.2.rulesets (351.3 KB) - added by stars 8 years ago.
.mozilla/firefox/profile/extensions/https-everywhere@…/chrome/content/rules

Download all attachments as: .zip

Change History (13)

comment:1 Changed 8 years ago by stars

Cc: stars@… added

hi,

I get the same error after the last update of "https-everywhere"

Best Regards

SwissTorHelp

comment:2 Changed 8 years ago by pde

Status: newaccepted

This error is in your browser Error console or shell, right?

comment:3 Changed 8 years ago by pde

For the moment I can't reproduce or see and explanation for this, either. Are you running a packaged version of HTTPS Everywhere from Debian/RedHat/Tor Browser Bundle?

Also, can you check that you have no custom rulesets in the HTTPSEverywhereUserRules/ subdirectory of your firefox profile dir?

comment:4 Changed 8 years ago by stars

Hi pde,

yes, i found it in my browser console..

About the "HTTPSEverywhereUserRules/ ", it's empty

comment:5 in reply to:  4 Changed 8 years ago by stars

Replying to stars:

Hi pde,

yes, i found it in my browser console..

About the "HTTPSEverywhereUserRules/ ", it's empty

Actually i use the "JondoFox" plug-in who include Https everywhere but it's the same for new profile or Torbutton

I use Kubuntu Lucid LTS 64 bits 10.04.3 and Firefox 8.0 from repo

comment:6 Changed 8 years ago by pde

Can you post a copy of your system's "default.rulesets" file(s) somewhere?

comment:7 Changed 8 years ago by stars

i don't know what's the used by the profile's but i add one who are in :

/.mozilla/firefox/avjs7hib.default/extensions/https-everywhere@…/chrome/content/rules

and the second in :

.mozilla/firefox/profile/extensions/https-everywhere@…/chrome/content/rules

I hope that's help you :)

Changed 8 years ago by stars

Attachment: default.rulesets added

/.mozilla/firefox/avjs7hib.default/extensions/https-everywhere@…/chrome/content/rules

Changed 8 years ago by stars

Attachment: default.2.rulesets added

.mozilla/firefox/profile/extensions/https-everywhere@…/chrome/content/rules

comment:8 Changed 8 years ago by pde

It seems very likely that you're seeing this message because you have two (identical) copies of default.rulesets kicking around.

I don't know what the .mozilla/firefox/profile/extensions directory is. I'm wondering if that's something that might be put there by JonDoFox, in which case that could be the cause of the problem.

comment:9 Changed 8 years ago by pde

Priority: normalminor

comment:10 Changed 8 years ago by carenas

Cc: carenas@… added

as shown in the Description of the bug, the problem is not triggered by a duplicate default but the fact that there is an extra file which probably shouldn't had been packaged in 2.2.1 (named GoogleMaps.xml~HEAD which might seem a leftover from a merge conflict) and that has a duplicate rule for google maps :

chrome/content/rules/GoogleMaps.xml~HEAD:
<ruleset name="GoogleMaps">

<target host="maps.google.com" />
<target host="maps.gstatic.com" />
<target host="maps-api-ssl.google.com"/>
<target host="maps.googleapis.com"/>
<target host="maps.google.*"/>
<target host="maps.google.com.*"/>
<target host="maps.google.co.*"/>

<securecookie host="maps\.google\.(com?\.)?(au|ca|gh|ie|in|jm|ke|lk|my|na|ng|nz|pk|rw|sl|sg|ug|uk|za|zw)$" name=".*"/>
<securecookie host="
maps\.(google|gstatic|googleapis)\.com$" name=".*"/>
<securecookie host="maps-api-ssl\.google\.com$" name=".*"/>

<rule from="http://maps\.(google|gstatic|googleapis)\.com/" to="https://maps.$1.com/"/>
<rule from="
http://maps\.google\.([^/]+)/" to="https://maps.google.$1/"/>
<rule from="http://maps-api-ssl\.google\.com/" to="https://maps-api-ssl.google.com/"/>

</ruleset>

chrome/content/rules/default.rulesets
<ruleset name="GoogleMaps">

<target host="maps.google.com" />
<target host="maps.gstatic.com" />
<target host="maps-api-ssl.google.com"/>
<target host="maps.googleapis.com"/>
<target host="maps.google.*"/>
<target host="maps.google.com.*"/>
<target host="maps.google.co.*"/>

<securecookie host="maps\.google\.(com?\.)?(au|ca|gh|ie|in|jm|ke|lk|my|na|ng|nz|pk|rw|sl|sg|ug|uk|za|zw)$" name=".*"/>
<securecookie host="
maps\.(google|gstatic|googleapis)\.com$" name=".*"/>
<securecookie host="maps-api-ssl\.google\.com$" name=".*"/>

<rule from="http://maps\.(google|gstatic|googleapis)\.com/" to="https://maps.$1.com/"/>
<rule from="
http://maps\.google\.([^/]+)/" to="https://maps.google.$1/"/>
<rule from="http://maps-api-ssl\.google\.com/" to="https://maps-api-ssl.google.com/"/>

</ruleset>

to replicate just download the xpi file from :

https://www.eff.org/files/https-everywhere-1.2.1.xpi

and deploy it or inspect at its contents

comment:11 Changed 8 years ago by pde

Resolution: fixed
Status: acceptedclosed

Oh, thanks for spotting that bizarre merge conflict file. It should be fixed in future (post 1.2.2) releases.

Note: See TracTickets for help on using tickets.