Opened 8 years ago

Closed 8 years ago

#4512 closed defect (fixed)

javascript on download pages ignores versions.wmi

Reported by: phobos Owned by: phobos
Priority: Medium Milestone:
Component: Webpages/Website Version:
Severity: Keywords:
Cc: jmtodaro Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The javascript on the download pages seems to use a different file for filenames. As the versions.wmi file is updated, the changes are not reflected in the download/download-easy javascript. This is currently breaking the android download.

Child Tickets

Attachments (1)

androidfix.diff (769 bytes) - added by jmtodaro 8 years ago.
Repair broken Android package link (download.wmi)

Download all attachments as: .zip

Change History (7)

comment:1 Changed 8 years ago by phobos

it appears the problem is that download/download-easy use the versions rather than the package definitions. We should be using <package-torbrowser-bundle> instead of href="../dist/torbrowser/tor-browser-<version-torbrowserbundle>_<lang>.exe">

comment:2 Changed 8 years ago by jmtodaro

In versions.wmi, the <package-androidbundle-alpha> variable is malformed and should have '../' added before 'dist/' i.e. '../dist/android/Orbot-<version-androidbundle-orbot>-Tor-<version-androidbundle-tor>-FINAL.apk'. I can add it into the downoad page manually if needed, but the other links in versions.wmi have the '../' included as part of the path.

The problem with the rest of the packages is that it was necessary to use '(hardcoded directory path)/<version-torbrowserbundle>_<lang>' format to make language selection possible.

Do we still need language selection? If not, I can just update the links and be done with it. Otherwise I'll try to update the hardcoded directory paths and fix some of the version variables in the page so that everything works the way it is supposed to.

comment:3 Changed 8 years ago by jmtodaro

Sorry, I was looking at the wrong package last time. The other links I checked seem to be working as they are supposed to. What is currently being served matches up with what is in versions.wmi anyhow. Do you have another specific example of a package link not being updated to the latest version?

Here's the fix for that Android link.

Changed 8 years ago by jmtodaro

Attachment: androidfix.diff added

Repair broken Android package link (download.wmi)

comment:4 Changed 8 years ago by phobos

Yes, we still need language selection. My concern is that we're hardcoding package names into the javascript, instead of using the package- definitions in versions.wmi. I guess this is required for each language for TBB. An option is to define TBB packages, one per language so the javascript just calls package-tbb-stable-lang instead of "../dist/torbrowser/linux/tor-browser-gnu-linux-i686-<version-torbrowserbundlelinux32>-dev-<lang>.tar.gz".

comment:5 Changed 8 years ago by jmtodaro

I don't think this is necessary. As I mentioned before, all versions being served up are current as far as I can tell. Can you show me a specific example of a package not updating on the live website properly?

The javascript does not ignore versions.wmi. The cause of the broken android link was unrelated and fixed in the patch I attached.

comment:6 Changed 8 years ago by phobos

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.