Opened 6 years ago

Closed 6 years ago

#4601 closed defect (fixed)

Arm torrc validation fails on Tor Cloud

Reported by: atagar Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Nyx Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor's config parsing is case insensitive, so arm's validation should be too. At present having "Exitpolicy reject *:*" in the torrc is counted as both being unnecessary and missing since it doesn't match "ExitPolicy reject *:*".

Child Tickets

Change History (8)

comment:1 Changed 6 years ago by james21

Can I also add that this is a particular issue for less informed users as the implication is that we should remove the line. In fact I did just that until I worked out maybe it wasn't such a good idea!

comment:2 Changed 6 years ago by atagar

Status: newneeds_information

The original requester of this ticket is having trouble reproducing the issue and so am I with...

SocksPort 0
ControlPort 9051
orport 9050
exitpolicy reject *:*

Looks like we're wrong about the root cause of whatever koolfy is encountering with the tor cloud image. :/

james21: Do you have steps for reproducing this issue?

comment:3 Changed 6 years ago by james21

A vanilla build of the Tor Cloud image with Arm from the lucid-backports repository (1.4.0.1-2~lucid1).

comment:4 Changed 6 years ago by james21

This may be unrelated but I also receive this warning:

[ARM_WARN] The torrc differ from what tor's using. You can issue a sighup to reload the torrc values by pressing x.
-configuration value is missing from the torrc: Log

comment:5 Changed 6 years ago by atagar

Component: armTor Cloud
Owner: changed from atagar to Runa
Status: needs_informationassigned

A vanilla build of the Tor Cloud image with Arm from the lucid-backports repository

Tor cloud was where the original reporter also mentioned seeing it. I'm not sure what's special about that environment. Worst case Runa said that she'll look at it in a month or so when the ubuntu image updates. Assigning to her.

This may be unrelated but I also receive this warning:

It is different. For that issue see...
https://trac.torproject.org/projects/tor/ticket/4602

comment:6 Changed 6 years ago by atagar

Summary: Arm torrc validation case sensetiveArm torrc validation fails on Tor Cloud

comment:7 in reply to:  5 Changed 6 years ago by runa

Owner: changed from Runa to atagar

Replying to atagar:

A vanilla build of the Tor Cloud image with Arm from the lucid-backports repository

Tor cloud was where the original reporter also mentioned seeing it. I'm not sure what's special about that environment. Worst case Runa said that she'll look at it in a month or so when the ubuntu image updates. Assigning to her.

I said I would probably run into the bug in a month or so, not that I would look into it. Anyways, I can set up an instance for you and give you the key so that you can access it and test this yourself. Drop me an email and I'll sort it out.

comment:8 Changed 6 years ago by atagar

Component: Tor Cloudarm
Resolution: fixed
Status: assignedclosed

Ah ha! I was failing to repro because the tor version I was using was missing 'GETINFO config-text', causing all torrc validation to be skipped. This was indeed the original case sensitivity issue we thought. Reproed on a Tor Cloud instance and fixed:
https://gitweb.torproject.org/arm.git/commitdiff/e7e4bb5a9a39857436620f71edba9092ff963247

Thanks kooly and Runa!

Note: See TracTickets for help on using tickets.