Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#4691 closed defect (fixed)

building libnatpmp doesn't work on unix

Reported by: Sebastian Owned by:
Priority: High Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-client
Cc: sjmurdoch, blueness Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Looks like while making libnatpmp compilation work for windows, we broke it for unix in 5dbfb1b3e0efc95be34ba7d69852511c9bac1f4b (now in 0.2.3.9-alpha). I can't test if compilation actually works on windows, hence I'm CCing sjm here who wrote the patch.

Child Tickets

Change History (7)

comment:1 Changed 8 years ago by Sebastian

Oh, before I forget. Reported by blueness, our gentoo maintainer.

comment:2 Changed 8 years ago by Sebastian

Cc: blueness added
Status: newneeds_review

If compilation works on Windows in 0.2.3.9-alpha, the patch in bug4691 in my repo is probably correct (it works for me in local testing). We should only merge it after we're sure that compilation on Windows works with it.

comment:3 Changed 8 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

I assert that this patch could not possibly break Windows builds, and that if it does, buildbot will tell us so before we put on an 0.2.3.10-alpha. Merging.

comment:4 Changed 8 years ago by Sebastian

Resolution: fixed
Status: closedreopened

Buildbot wouldn't tell us because we don't build the fw-helper there, tho.

comment:5 Changed 8 years ago by sjmurdoch

Resolution: fixed
Status: reopenedclosed

Thanks Sebastian, nick. I can confirm it still builds on Windows.

comment:6 Changed 7 years ago by nickm

Keywords: tor-client added

comment:7 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.