Opened 7 years ago

Closed 13 months ago

#4698 closed enhancement (not a bug)

MapAddress should be able to map from invalid .onion names

Reported by: katmagic Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-hs interface easy naming
Cc: the.magical.kat@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When one tries to access example.onion after MapAddress example.onion duskgytldkxiuqc6.onion has been added to the configuration file, Tor logs a warning, Invalid onion hostname [scrubbed]; rejecting.

Child Tickets

Change History (17)

comment:1 Changed 7 years ago by katmagic

Cc: the.magical.kat@… added

It looks like this only fails if the alias .onion is in an invalid format. For example, MapAddress abcdefghijklmnop.onion duskgytldkxiuqc6.onion works.

comment:2 Changed 7 years ago by nickm

Milestone: Tor: unspecified
Summary: MapAddress fails when both arguments are .onion addresses.MapAddress should be able to map from invalid .onion names

Changing the title of this issue to reflect requested behavior.

comment:3 Changed 6 years ago by nickm

Keywords: tor-hs added

comment:4 Changed 6 years ago by nickm

Component: Tor Hidden ServicesTor

comment:5 Changed 4 years ago by nickm

Milestone: Tor: unspecifiedTor: 0.2.7.x-final

Worth looking at during 0.2.7 triage IMO

comment:6 Changed 4 years ago by nickm

Status: newassigned

comment:7 Changed 4 years ago by nickm

Keywords: 027-triaged-1-out added

Marking triaged-out items from first round of 0.2.7 triage.

comment:8 Changed 4 years ago by nickm

Milestone: Tor: 0.2.7.x-finalTor: 0.2.???

Make all non-needs_review, non-needs_revision, 027-triaged-1-out items belong to 0.2.???

comment:9 Changed 3 years ago by dgoulet

Keywords: mapaddress 027-triaged-1-out removed
Priority: MediumLow
Severity: Normal
Sponsor: None

comment:10 Changed 3 years ago by nickm

Sponsor: None

Change Core Tor tickets with sponsor "None" to "", per our practice elsewhere. This will help sorting.

comment:11 Changed 2 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:12 Changed 2 years ago by nickm

Keywords: tor-03-unspecified-201612 added
Milestone: Tor: 0.3.???Tor: unspecified

Finally admitting that 0.3.??? was a euphemism for Tor: unspecified all along.

comment:13 Changed 22 months ago by nickm

Keywords: tor-03-unspecified-201612 removed

Remove an old triaging keyword.

comment:14 Changed 22 months ago by nickm

Status: assignednew

Change the status of all assigned/accepted Tor tickets with owner="" to "new".

comment:15 Changed 22 months ago by nickm

Keywords: interface easy naming added
Priority: LowMedium

I agree this is a good idea, and probably smart to have.

comment:16 Changed 13 months ago by fristonio

I Would like to work on this, any specific part of codebase I should start with?

comment:17 Changed 13 months ago by fristonio

Resolution: not a bug
Status: newclosed

This issue does not exist in tor as of now.
Tested on Tor Browser and Firefox, MapAddress works perfectly fine.

Note: See TracTickets for help on using tickets.