Opened 7 years ago

Closed 4 years ago

Last modified 16 months ago

#4716 closed defect (fixed)

vidalia-0.2.15-1~oneiric tries to start a per-user Tor with system-wide settings

Reported by: tigerjack89 Owned by: dererk
Priority: Immediate Milestone:
Component: Applications/Tor bundles/installation Version: Tor: 0.2.2.34
Severity: Normal Keywords: Ubuntu, 11.10, 64, bit, needs-triage
Cc: chiiph Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi all!!
I hope this is the correct way to contact the Tor Vidalia bundle developers; if not, I'm sorry, but this is the only way I have to communicate with someone.
I usu Ubuntu 11.10 64bit. Yesterday I update my Vidalia version from the repository below.

deb http://deb.torproject.org/torproject.org oneiric main

Now, when I start Vidalia, I have an error message; this is the content of logfile

dic 14 14:28:28.306 [Notice] Tor v0.2.2.34 (git-c55c166e73d500af). This is experimental software. Do not rely on it for strong anonymity. (Running on Linux x86_64)
dic 14 14:28:28.307 [Notice] Initialized libevent version 1.4.14b-stable using method epoll. Good.
dic 14 14:28:28.307 [Notice] Opening Socks listener on 127.0.0.1:9050
dic 14 14:28:28.307 [Notice] Opening Control listener on 127.0.0.1:9051
dic 14 14:28:28.308 [Warning] Directory /var/run/tor does not exist.
dic 14 14:28:28.308 [Warning] Before Tor can create a control socket in "/var/run/tor/control", the directory "/var/run/tor" needs to exist, and to be accessible only by the user account that is running Tor. (On some Unix systems, anybody who can list a socket can conect to it, so Tor is being careful.)
dic 14 14:28:28.308 [Notice] Closing partially-constructed listener Socks listener on 127.0.0.1:9050
dic 14 14:28:28.308 [Notice] Closing partially-constructed listener Control listener on 127.0.0.1:9051
dic 14 14:28:28.308 [Warning] Failed to parse/validate config: Failed to bind one of the listener ports.
dic 14 14:28:28.308 [Error] Reading config failed--see warnings above.

Then I created the tor directory in /var/run/ and changed his owner to me, as request by vidalia. As a result I have the same error and the only change in logfile is in bolded text, changed in
dic 14 14:32:19.405 [Warning] Permissions on directory /var/run/tor are too permissive.

Previous version was full functionally.

Thanks a lot for your hard work. I hope this mail can help you to improve program :)
Kinda regards
Simone

Child Tickets

Change History (16)

comment:1 Changed 7 years ago by rransom

Component: - Select a componentTor bundles/installation
Status: newneeds_information

What does the command dpkg -s tor |grep '^Version: ' print?

comment:2 Changed 7 years ago by tigerjack89

Version: 0.2.2.34-1~oneiric+1

comment:3 Changed 7 years ago by rransom

Cc: chiiph added
Owner: set to dererk
Status: needs_informationassigned
Summary: Bug on oreniric last updatevidalia-0.2.15-1~oneiric tries to start a per-user Tor with system-wide settings

I just installed vidalia-0.2.15-1~oneiric from deb.tpo, told debconf to add my user account to the debian-tor group, and ran Vidalia, and I got these error messages:

Dec 14 07:04:10.811 [Notice] Tor v0.2.3.9-alpha (git-ba3267ad038b77ca) running on Linux i686.
Dec 14 07:04:10.811 [Notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Dec 14 07:04:10.811 [Notice] This version is not a stable Tor release. Expect more bugs than usual.
Dec 14 07:04:10.811 [Notice] Read configuration file "/home/rransom/.vidalia/torrc".
Dec 14 07:04:10.811 [Notice] Initialized libevent version 2.0.12-stable using method epoll (with changelist). Good.
Dec 14 07:04:10.812 [Notice] Opening Socks listener on 127.0.0.1:9050
Dec 14 07:04:10.812 [Warning] Could not bind to 127.0.0.1:9050: Address already in use. Is Tor already running?
Dec 14 07:04:10.812 [Warning] /var/run/tor is not owned by this user (rransom, 1000) but by debian-tor (114). Perhaps you are running Tor as the wrong user?
Dec 14 07:04:10.812 [Warning] Before Tor can create a control socket in "/var/run/tor/control", the directory "/var/run/tor" needs to exist, and to be accessible only by the user account that is running Tor.  (On some Unix systems, anybody who can list a socket can conect to it, so Tor is being careful.)
Dec 14 07:04:10.812 [Warning] Failed to parse/validate config: Failed to bind one of the listener ports.
Dec 14 07:04:10.812 [Error] Reading config failed--see warnings above.

I had not installed or run Vidalia on this computer before (except as part of TBB). Vidalia is, in its default configuration, trying to start its own Tor instance, using configuration settings for a system Tor instance.

comment:4 Changed 7 years ago by tigerjack89

I don't know what the things you've written mean lol.
What I have to do? How can I help you?

comment:5 Changed 7 years ago by dererk

Can you confirm you have effectively re-logged your X session before starting Vidalia for the very first time?

comment:6 Changed 7 years ago by tigerjack89

I restart the whole system a few times, if it is what you ask.
I have always the same error.

comment:7 in reply to:  1 Changed 7 years ago by cypherpunks

Replying to rransom:

What does the command dpkg -s tor |grep '^Version: ' print?

Version: 0.2.2.34-1~lucid+1

I get the same error using lucid, obviously. Tor and vidalia are from torproject.org deb. There was a vidalia update incoming (0.2.15), while installing it asked which user to put into "debian-tor" group, i selected the user i'm running tor with. Now, when starting vidalia i always get this error

comment:8 Changed 7 years ago by rransom

Priority: criticalblocker

We just had a user complain about brokenness which sounded like this bug in #tor.

comment:9 Changed 7 years ago by dererk

Mind to check that you are indeed starting Tor on system session and not in the user's session?

This is quite important, since both, tor and vidalia's defaults configurations wont work nicely together if you start Tor's on user's session basis.

comment:10 in reply to:  9 Changed 7 years ago by tigerjack89

I apologize for the delay.
I start vidalia on my user, which is the only user. Before the update I have no problem with the two programs.
What do you mean as system session?

comment:11 Changed 7 years ago by dererk

I meant that you have indeed started Tor daemon in advance.

The Tor software is capable of running under different configurations or profiles to provide different usages.
Vidalia is configured by default to use Tor's system-wide sessions, that is, you have a Tor service/daemon running on your machine in advance on starting Vidalia, so the last one can talk to it nice and easily without any configuration at all.

Simplest way to do this, by far, is performing this actions:

  1. Check whether Tor is running on a system-wide basis -> /etc/init.d/tor status
  2. If it's not, but a list of the processes running shows one, kill it
  3. Proceed to start tor's daemon -> /etc/init.d/tor start
  4. Then, with your regular X user (NOT ROOT USER!), start Vidalia.

If this fails at some point, please copy&paste everything that its output on logs (/var/log/tor/log and vidalia's log)

comment:12 Changed 7 years ago by runa

Please see #4805 for additional information about this issue.

comment:13 Changed 7 years ago by dererk

Root cause found on #4823.

comment:14 Changed 5 years ago by erinn

Keywords: needs-triage added

comment:15 Changed 4 years ago by cypherpunks

Resolution: fixed
Status: assignedclosed

Vidalia is deprecated.

comment:16 Changed 16 months ago by teor

Severity: Normal

Set all tickets without a severity to "Normal"

Note: See TracTickets for help on using tickets.