Opened 3 years ago

Closed 3 years ago

#4735 closed defect (fixed)

HTTPS Everywhere breaks pogo.com avatar editing

Reported by: tmpname0901 Owned by: pde
Priority: normal Milestone:
Component: EFF-HTTPS Everywhere Version:
Keywords: Cc:
Actual Points: Parent ID:
Points:

Description

When logged into the gaming site Pogo (pogo.com) users can customize their avatar from the "Mini-Mall", opting to change things like hair style, clothing and background image.

With HTTPS Everywhere v1.2.1 installed this does not work. The Mini-Mall page simply shows the current avatar, with no options for editing it. Disabling Pogo in the HTTPS Everywhere settings fixes this problem.

This is the working URL, with Pogo excluded from HTTPS Everywhere:

http://www.pogo.com/avatar/edit.do?pageSection=cp_home_my_stuff

Child Tickets

Change History (4)

comment:1 Changed 3 years ago by tmpname0901

  • Component changed from HTTPS Everywhere: Chrome to EFF-HTTPS Everywhere
  • Owner changed from aaronsw to pde

Oops! Selected wrong component for report. This is seen with Firefox, not Chrome.

comment:2 Changed 3 years ago by pde

  • Status changed from new to accepted

I've tried to hack an exclusion for this in git:

https://gitweb.torproject.org/https-everywhere.git/commitdiff/60be1e9ef86065b412dfa0be7af191826758484b

However I don't have a Pogo account, so I can't test it quickly.

If you're comfortable building a .xpi from git, can you let me know if this works? If not we can find out after the next release.

comment:3 Changed 3 years ago by tmpname0901

Sorry, I just saw this reply now.

The .xpi is just a renamed ZIP archive, right? I guess I can zip a directory tree as well as the next guy. I'll try it tomorrow and get back to you.

comment:4 Changed 3 years ago by pde

  • Resolution set to fixed
  • Status changed from accepted to closed

(You wouldn't normally manually zip the tree; running "make" on a unix system will run some scripts that do it for you).

In any case, this patch is in the 1.2.2 stable release; reopen this bug if the problem is still present!

Note: See TracTickets for help on using tickets.