Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#4752 closed defect (not a bug)

Older command-line behavior of -log might be more reasonable

Reported by: nickm Owned by:
Priority: Medium Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

On tor-talk, Jim reports:

I am wondering if this follows the principle of least surprise, at

least with regard to logging. I was initially baffled why this release
was not logging anything to the system log and thought it to be a bug.
I then realized that the config file's "Log notice syslog" had been
disabled by the command line's --log "notice stdout", which I was piping
to a script. Expected behavior returned when I changed --log to --+log.

(See https://lists.torproject.org/pipermail/tor-talk/2011-December/022328.html )

This change was made so we could get defaults torrcs to work sensibly, and to restore sensible behavior for socksport, etc. But it breaks expectations for the log directive.

One option here is to have different options work differently.

Another option is to have the torrc->commandline border work differently from the defaults->torrc border.

And a third option is to say "yeah, we're changing old expectations here", and document it better.

Whatever we do, we should do it on an 0.2.3.x timeframe.

Child Tickets

Change History (6)

comment:1 Changed 9 years ago by Sebastian

I like option three as the cleanest way to go forward, especially because option one will be a nightmare to document properly and our options are already _really_ confusing to most users.

What we *could* do on top of option three is add some warnings when you define some options, like Log for example, on command line and in the torrc file. Then we can help with some surprises, and yet have a clear and consistent way in which options from different files/command line interact

comment:2 Changed 8 years ago by nickm

Agreed that documentation is the answer.

comment:3 Changed 8 years ago by nickm

Documented the new behavior for multi-line options in my branch for bug #4748 (bug4748 in my public repo). Any further suggestions?

comment:4 Changed 8 years ago by nickm

Resolution: not a bug
Status: newclosed

bug4748 is merged; closing this as done.

comment:5 Changed 8 years ago by nickm

Keywords: tor-client added

comment:6 Changed 8 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.