Opened 7 years ago

Closed 7 years ago

Last modified 19 months ago

#4754 closed defect (worksforme)

Firefox fails to start if Torbutton is enabled and the network is inaccessible.

Reported by: katmagic Owned by: mikeperry
Priority: Immediate Milestone:
Component: Applications/Torbutton Version:
Severity: Normal Keywords:
Cc: mikeperry, the.magical.kat@…, erinn Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

If Torbutton is enabled when Firefox boots, it makes two requests to check.torproject.org through Tor. If this request fails, Torbutton will simply try again, and again, and again, and again… Until a successful request is made, Firefox will not start.

This causes two major problems. The more common and less severe one is that it dramatically increases Firefox's startup time. The second is that if the user is connected to a network that requires them to perform some action through a web interface (e.g. logging in or accepting a ToS agreement), they'll find themselves in a perverse, Freenode-esque catch-22 where they can't connect to the network unless they disable Torbutton, and can't disable Torbutton until they connect to the network.

Child Tickets

Change History (8)

comment:1 Changed 7 years ago by katmagic

Cc: the.magical.kat@… added

comment:2 Changed 7 years ago by rransom

This must be Torbutton's update check.

comment:3 Changed 7 years ago by erinn

Cc: erinn added

comment:4 Changed 7 years ago by mikeperry

There is nothing in torbutton's version check code to make it retry in the event of a failure. I'm not sure what is causing the behavior you see. Maybe you are mistaken, and check is simply allowing the TCP connection to be established, but never returning data?

See https://gitweb.torproject.org/torbutton.git/blob/HEAD:/src/chrome/content/torbutton.js#l2858 and https://gitweb.torproject.org/torbutton.git/blob/HEAD:/src/chrome/content/torbutton.js#l888

I heard something about a DDoS on cymru? Maybe that is the cause?

comment:5 Changed 7 years ago by erikd

I've justed tested this on Linux (FF 8.0) and I can't reproduce it either.

katmagic, what OS are you on and what version of FF are you using?

comment:6 in reply to:  description Changed 7 years ago by rransom

Replying to katmagic:

If Torbutton is enabled when Firefox boots, it makes two requests to check.torproject.org through Tor. If this request fails, Torbutton will simply try again, and again, and again, and again… Until a successful request is made, Firefox will not start.

I tested this in TBB 2.2.35-4, using “MapAddress check.torproject.org 1.1.1.1” to cause all connection attempts to check.tpo to fail, and didn't see any retries. (I saw one pair of streams attempting to connect to 1.1.1.1:443 before the TBB-Firefox window appeared, and one pair after the TBB-Firefox window appeared for the home-page load.)

comment:7 Changed 7 years ago by mikeperry

Resolution: worksforme
Status: newclosed

comment:8 Changed 19 months ago by teor

Severity: Normal

Set all tickets without a severity to "Normal"

Note: See TracTickets for help on using tickets.