Opened 9 years ago

Last modified 10 months ago

#4763 new defect

TorBrowser remembers location of last locally-opened file: "File > Open File ..."

Reported by: cypherpunks Owned by: tbb-team
Priority: Low Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: ux-team
Cc: TBBnoob@…, mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This seems like less-than-ideal behavior.

Ex., TBB is used as the local Tor, Vidalia and browser by Alice, on her computer. However, Bob also has access to Alice's computer because they live together. Alice was looking at a local file she doesn't want Bob to see, but Bob does see the file when he too uses TBB as the local Tor, Vidalia and browser. Of course, Bob found the local file by mistake when he was trying to open a different local file.

Child Tickets

Change History (18)

comment:1 Changed 9 years ago by mikeperry

Status: newneeds_information

This report is very vague and unlikely to be solved as-is. How did Bob "see" the local file? Did you enable history? Was it present on-disk? Please provide more details.

comment:2 Changed 5 years ago by bugzilla

Component: Firefox Patch IssuesTor Browser
Severity: Normal

comment:3 Changed 16 months ago by gaba

Cc: mikeperry added
Owner: mikeperry deleted
Status: needs_informationassigned

comment:4 Changed 11 months ago by gk

Resolution: user disappeared
Status: assignedclosed

comment:5 Changed 11 months ago by cypherpunks

Resolution: user disappeared
Status: closedreopened

The user disappeared, but the problem didn't.

comment:6 Changed 11 months ago by gk

Resolution: user disappeared
Status: reopenedclosed

Please only reopen the ticket with steps to reproduce the problem. In particular, please provide the information requested in comment:1 over 8 years ago. Thanks.

Last edited 11 months ago by gk (previous) (diff)

comment:7 Changed 11 months ago by Thorin

No need for STR - it's a straightforward - File>Open>... (e.g. from menu bar or ctrl-O). The information is persistent and stored by the pref browser.open.lastDir (which is a hidden pref). I guess you could reset it on each new identity see [1] PB mode does not use this pref

[1] https://dxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#2910

Edit: that was in quick test in Firefox. Testing Tor Browser (alpha), it doesn't use that pref, but still remembers the location. TB did pick up my Firefox's location If someone has access to your PC already, you have bigger things to worry about.

Last edited 11 months ago by Thorin (previous) (diff)

comment:8 Changed 11 months ago by cypherpunks

Resolution: user disappeared
Status: closedreopened

Even Thorin knows it doesn't need additional STR, because the summary is self-descriptive, heh.

comment:9 in reply to:  7 Changed 11 months ago by gk

Replying to Thorin:

No need for STR - it's a straightforward - File>Open>... (e.g. from menu bar or ctrl-O). The information is persistent and stored by the pref browser.open.lastDir (which is a hidden pref). I guess you could reset it on each new identity see [1] PB mode does not use this pref

[1] https://dxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#2910

Edit: that was in quick test in Firefox. Testing Tor Browser (alpha), it doesn't use that pref, but still remembers the location. TB did pick up my Firefox's location If someone has access to your PC already, you have bigger things to worry about.

Yeah, this should not be an issue in Private Browsing Mode, see: https://searchfox.org/mozilla-esr68/source/browser/base/content/browser.js#2950ff.

comment:10 in reply to:  7 Changed 11 months ago by gk

Resolution: worksforme
Status: reopenedclosed

Replying to Thorin:

No need for STR - it's a straightforward - File>Open>... (e.g. from menu bar or ctrl-O). The information is persistent and stored by the pref browser.open.lastDir (which is a hidden pref). I guess you could reset it on each new identity see [1] PB mode does not use this pref

[1] https://dxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#2910

Edit: that was in quick test in Firefox. Testing Tor Browser (alpha), it doesn't use that pref, but still remembers the location. TB did pick up my Firefox's location If someone has access to your PC already, you have bigger things to worry about.

I am not convinced. I tried the following thing on my Linux box:

1) Clean new 9.5a3 en-US bundle
2) I opened a local file in my Tor Browser (as that's what the op reported)
3) I closed the browser
4) I looked at File -> Open after a restart and nothing showed up under last opened files.

Again, please provide steps to reproduce.

comment:11 Changed 11 months ago by cypherpunks

Resolution: worksforme
Status: closedreopened

4) I looked at File -> Open after a restart and nothing showed up under last opened files.

Not files, just folder ('location' in the Summary). And... Windows.

comment:12 Changed 11 months ago by Thorin

And... Windows.

Was just going to say that this might be windows only. I'll dig more later

In my initial tests, on FF I opened a file from location A. In TB I went ctrl-O and it started the dialog at location A (so where did it get that from?), so I changed it to use location B. I closed TB, opened TB, and on ctrl-O it used location B.

4) I looked at File -> Open after a restart ... last opened files

Location.... location ... location :)

comment:13 in reply to:  11 Changed 11 months ago by gk

Resolution: worksforme
Status: reopenedclosed

Replying to cypherpunks:

4) I looked at File -> Open after a restart and nothing showed up under last opened files.

Not files, just folder ('location' in the Summary). And... Windows.

Nope under Windows I only see the Download directory of the current user when opening File -> Open. It does not change if I open file:///C: and then open files by move up and down directories and click on them.

comment:14 in reply to:  12 ; Changed 11 months ago by gk

Keywords: ux-team added
Resolution: worksforme
Status: closedreopened

Replying to Thorin:

And... Windows.

Was just going to say that this might be windows only. I'll dig more later

In my initial tests, on FF I opened a file from location A. In TB I went ctrl-O and it started the dialog at location A (so where did it get that from?), so I changed it to use location B. I closed TB, opened TB, and on ctrl-O it used location B.

4) I looked at File -> Open after a restart ... last opened files

Location.... location ... location :)

Okay, the plot thickens. I opened the file by navigating via the URL bar. That's cool. The bug occurs if one opens the file Ctrl+O first, then close the browser and reopens it. Adding the ux team for input as to whether we want to change anything here.

comment:15 in reply to:  14 Changed 11 months ago by Thorin

Replying to gk:

Okay, the plot thickens. I opened the file by navigating via the URL bar. That's cool. The bug occurs if one opens the file Ctrl+O first, then close the browser and reopens it. Adding the ux team for input as to whether we want to change anything here.

Not just Ctrl+O which is just a shortcut key to trigger the open dialog. I tested if the remembered location changed by dragging and dropping a file into the urlbar, and that doesn't change anything. So it's explicitly triggered by the windows open dialog.

What happens on a Mac?

comment:16 Changed 11 months ago by gk

Status: reopenednew

comment:17 Changed 10 months ago by gk

Owner: set to tbb-team
Status: newassigned

comment:18 Changed 10 months ago by gk

Status: assignednew
Note: See TracTickets for help on using tickets.