Opened 8 years ago

Closed 5 years ago

#4782 closed defect (duplicate)

Firefox gives confusing error message (or crashes) when TBB is run from a directory which it cannot write to

Reported by: kikoulol Owned by: mikeperry
Priority: High Milestone: TorBrowserBundle 2.3.x-stable
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-disk-leak, tbb-usability-stoppoint-app, tbb-3.0, tbb-helpdesk-frequent, tbb-firefox-patch
Cc: erinn, chiiph, Shondoit, gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I can't run Tor Browser Bundle properly as a normal user on Windows 7. Vidalia starts and loads well, but after the connection is established, a message box says : "Firefox is already running. Please ..." whereas all instances of firefox are closed (yes I'm sure). And so the application exits.

As an administrator, there is not the same problem.

Child Tickets

Change History (19)

comment:1 Changed 8 years ago by phobos

Component: - Select a componentTor Browser
Owner: set to mikeperry

I just tested this on Win7, fully patched. Latest TBB works fine in 64bit win7 pro as a normal user.

comment:2 Changed 8 years ago by phobos

Can you start the bundle via command line, passing --debug to the 'start tor browser.exe' command? It should create a debug log in the same directory which will detail what is occurring on start up.

comment:3 in reply to:  2 Changed 8 years ago by rransom

Replying to phobos:

Can you start the bundle via command line, passing --debug to the 'start tor browser.exe' command? It should create a debug log in the same directory which will detail what is occurring on start up.

The Windows TBB startup program doesn't support a --debug option.

comment:4 in reply to:  description ; Changed 8 years ago by rransom

Status: newneeds_information

Replying to kikoulol:

I can't run Tor Browser Bundle properly as a normal user on Windows 7. Vidalia starts and loads well, but after the connection is established, a message box says : "Firefox is already running. Please ..." whereas all instances of firefox are closed (yes I'm sure). And so the application exits.

As an administrator, there is not the same problem.

Did you unpack TBB as an administrator? It should be unpacked by the user account which will run int.

comment:5 in reply to:  4 Changed 8 years ago by kikoulol

Resolution: not a bug
Status: needs_informationclosed

Replying to rransom:

Did you unpack TBB as an administrator? It should be unpacked by the user account which will run int.

That's it ! Thank you for you very quick response :-)

comment:6 Changed 8 years ago by rransom

Cc: erinn chiiph added
Resolution: not a bug
Status: closedreopened
Summary: Impossible to run Tor Browser Bundle on Windows 7 as normal userFirefox gives confusing error message when TBB is run from a directory which it cannot write to

Reopening, because velope reports that multiple users have asked for help with this in #tor. We should try to detect this situation (TBB started by a user who does not have write access to the TBB directory, whether due to permissions or a read-only filesystem) before starting Firefox.

This check can be implemented either in Vidalia or in RelativeLink.c (compiled to “Start Tor Browser.exe”), and it may require marking the program which performs the check so that Windows won't ‘virtualize’ the filesystem (i.e. divert writes to a subdirectory of the user's AppData directory).

comment:7 Changed 8 years ago by Shondoit

Cc: Shondoit added

comment:8 in reply to:  6 Changed 8 years ago by Shondoit

Replying to rransom:

This check can be implemented either in Vidalia or in RelativeLink.c (compiled to “Start Tor Browser.exe”), and it may require marking the program which performs the check so that Windows won't ‘virtualize’ the filesystem (i.e. divert writes to a subdirectory of the user's AppData directory).

The 'marking' needs to be done by the programs writing files. Since Firefox is already signed with a manifest file, it won't write to the VirtualStore (it's also why it gets a 'permission denied' for the lock).
Tor itself is not signed and probably does have this problem when TBB is unpacked in restricted folder. (Same for Vidalia.)

Recommendation: Sign tor.exe and Vidalia.exe as well as perform a 'writable' check in RelativeLink.c.

comment:9 Changed 8 years ago by mikeperry

Keywords: tbb-disk-leak added
Milestone: TorBrowserBundle 2.3.x-stable
Version: Tor: 0.2.2.35

I suspect this is a dup, but I can't find the canonical bug atm.

comment:10 Changed 8 years ago by mikeperry

#4894 is a similar permissions issue.

comment:11 in reply to:  10 Changed 7 years ago by Shondoit

arma says in #6129

If this is actually the behavior, one of the steps we should take is filing the bug with upstream. That's a mighty misleading error message for "I can't write to disk".

comment:12 Changed 7 years ago by mikeperry

Keywords: tbb-usability added

comment:13 Changed 6 years ago by mikeperry

Keywords: tbb-3.0 added
Priority: normalmajor
Summary: Firefox gives confusing error message when TBB is run from a directory which it cannot write toFirefox gives confusing error message (or crashes) when TBB is run from a directory which it cannot write to

Apparently, TBB 3.0 simply crashes in this case on Windows.

comment:14 Changed 5 years ago by mttp

Keywords: tbb-helpdesk-frequent added

To reduce confusion, the "Firefox is already running" message should be changed. There are occasions when an error message stating "Tor Browser is already running" would be accurate, but none when "Firefox is already running" would be. Users are trying to uninstall their installed Firefox to remedy this problem when they see it.

comment:15 Changed 5 years ago by erinn

Keywords: tbb-firefox-patch added

comment:16 Changed 5 years ago by erinn

Component: Firefox Patch IssuesTor Browser

comment:17 Changed 5 years ago by mikeperry

Keywords: tbb-usability-stoppoint-app added; tbb-usability removed

comment:18 Changed 5 years ago by gk

Cc: gk added

comment:19 Changed 5 years ago by mcs

Resolution: duplicate
Status: reopenedclosed

The work to provide improved error messages when profiles are not writeable, etc. is now being done in #14631.

Note: See TracTickets for help on using tickets.