Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#4784 closed defect (not a bug)

Exit enclave mode does not work

Reported by: Pascal Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.2.35
Severity: Keywords: exit enclave tor-relay
Cc: Pascal@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I setup a web server at http://173.213.78.125/ that shows you what IP address your tcp connection is coming from. I am running two Tor nodes on that same IP address, Pascal0 and Pascal1, both with "ExitPolicy accept 173.213.78.125:80" in their config files before "ExitPolicy reject *:*". Accessing the web server via Tor shows the originating IP address as that of other Tor relays. Tested with 0.2.2.35, 0.2.3.10, and 0.2.3.9. Both nodes appear to be passing other traffic correctly (averaging around 25Mbps each right now).

Child Tickets

Change History (5)

comment:1 Changed 8 years ago by Pascal

Cc: Pascal@… added

comment:2 Changed 8 years ago by Sebastian

Neither Pascal0 nor Pascal1 allow exiting to 173.213.78.125 (or any other IP address for that matter). You probably forgot to configure "ExitPolicyRejectPrivate 0". Also note that exit enclaves are brittle and don't work for the first connection to a node.

comment:3 Changed 8 years ago by nickm

Resolution: not a bug
Status: newclosed

comment:4 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:5 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.