Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#4785 closed defect (duplicate)

Never downgrade cells from RELAY_EARLY to RELAY.

Reported by: nickm Owned by:
Priority: Medium Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

To support v1 connections, we had a rule that any RELAY_EARLY cell sent over them had to be downgraded and sent as RELAY. Since 0.2.0.x is supposed to be dead, we can remove this. It will be needed to make #4339 work.

See #4339 for related issues. Based on a comment by wanoskarnet.

Child Tickets

Change History (3)

comment:1 Changed 8 years ago by nickm

Resolution: duplicate
Status: newclosed

This is a duplicate of #4786

comment:2 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:3 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.