Opened 8 years ago

Closed 7 years ago

#4792 closed defect (invalid)

Network throughput on tor relay stalls

Reported by: torland Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: 0.2.3.10-alpha
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Im am running the torland relay family. On one of my servers I experience sudden network outages. The relays normally pump at a rate of 450-550 MBit/s. When the outage happens, within minutes the rate goes down below about 5Mit/s. In this case it is difficult to connect to the server via ssh or to access the webserver with the traffic stats.
I checked the logs but found nothing in there. During the outage the CPU runs at a pretty low level, so CPU is not the root cause of this issue. Doing a traceroute to the server showed that the server indeed was the point where packet loss happened. I also contacted the ISP and asked them to check their network but they found nothing.
For me it looks as if the network stack on the machine runs at some point on some kind of lock which slows done throughout. Because the processes doing real work are tor processes (all are consuming nearly 100% CPU) I suppose tor is causing the outage. Are there any log options for tor I can use to investigate the cause of this issue?

Fingerprints of the relays are:
D223399907113A1F216AAA64997BC1D4CFA8E1AC
945CBBA599808018749DDC4EBB592168F2858C1B
09C0C5800177BF3A11A78A98A1CAFD8E7AD2EA02

Just to visualize I attach a screen shot of network usage when the issue happens: http://goo.gl/vSe32

Any hint is appreciated.

Child Tickets

Change History (7)

comment:1 Changed 7 years ago by nickm

Milestone: Tor: 0.2.3.x-final

comment:2 Changed 7 years ago by arma

The torservers.net people reported that they're triggering kernel problems sort of like this one. They solved it by limiting their relay to 95% of the cpu, so the kernel had some time to do its thing too.

comment:3 Changed 7 years ago by juwi

Status: newneeds_information

The screenshot is a 404, and It would also be interesting to know what OS/Kernel version this is on.

comment:4 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:5 Changed 7 years ago by nickm

Component: Tor RelayTor

comment:6 Changed 7 years ago by nickm

Milestone: Tor: 0.2.3.x-finalTor: unspecified

Did the torservers.net fix work? Any information on OS/kernel version?

comment:7 Changed 7 years ago by torland

Resolution: invalid
Status: needs_informationclosed

This did not happen again.

Note: See TracTickets for help on using tickets.