Opened 8 years ago

Closed 7 years ago

#4805 closed defect (duplicate)

Vidalia 0.2.15 update messed up with TOR config

Reported by: ggallozz Owned by: chiiph
Priority: Medium Milestone:
Component: Archived/Vidalia Version: Vidalia: 0.2.15
Severity: Keywords: update 0.2.15
Cc: dererk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

updating to this last version, it changed the TOR config, so that I was yet unableto access Internet with my Browser.
It changed the PROXY port and the TOR control port.
Impossible to change my '~/.vidalia/torrc' config file, or best said, unuseful, Vidalia don't recognize/load it anymore.
So I've only been able to get my environment functional back, downgrading to prior version 0.2.9

also, the Vidalia control panel HIDE button, shows randomly times to times

Ubuntu 10.10
TOR 0.2.2.35
Firefox 9.0

Child Tickets

Change History (11)

comment:1 Changed 8 years ago by ggallozz

forgot:
my HTTP proxy is Polipo, last version I guess (don't know how to get it)

comment:2 Changed 8 years ago by chiiph

Cc: dererk added
Milestone: Vidalia: 0.2.15
Priority: criticalnormal

Hi, a couple of questions to understand your problem better:

  • To be clear you are installing each component (Vidalia, Firefox, Tor, etc) by hand with the package manager? Or are you using the Tor Browser Bundle?
  • Could you provide Vidalia's advanced log for your failure so that we can see what the specific problem is?
  • Have you only updated Vidalia? Or Tor too? Tor's configuration to work with Vidalia in Debian and Ubuntu has changed, so an old Vidalia won't work with the latest Tor package in that Linux distribution, and neither will a new Vidalia with an old Tor. Because their configuration isn't compatible.

I'm adding dererk to this conversation, since this seems more likely a configuration issue rather than a code.

comment:3 Changed 8 years ago by travisp

I can confirm this bug. At some point in the last month or two, my tor/vidalia configuration stopped working after an upgrade from the repository. I am on Ubuntu 11.10 64-bit, with Tor version 0.2.2.35 and vidalia 0.2.15. I installed them using my package manager from the http://deb.torproject.org/torproject.org repository. They both previously worked fine together.

Error log:

Jan 02 14:04:56.192 [Notice] Tor v0.2.2.35 (git-73ff13ab3cc9570d). This is experimental software. Do not rely on it for strong anonymity. (Running on Linux x86_64)
Jan 02 14:04:56.192 [Notice] Initialized libevent version 2.0.12-stable using method epoll. Good.
Jan 02 14:04:56.192 [Notice] Opening Socks listener on 127.0.0.1:9050
Jan 02 14:04:56.192 [Warning] /var/run/tor is not owned by this user (travis, 1000) but by debian-tor (114). Perhaps you are running Tor as the wrong user?
Jan 02 14:04:56.192 [Warning] Before Tor can create a control socket in "/var/run/tor/control.authcookie", the directory "/var/run/tor" needs to exist, and to be accessible only by the user account that is running Tor.  (On some Unix systems, anybody who can list a socket can conect to it, so Tor is being careful.)
Jan 02 14:04:56.192 [Notice] Closing partially-constructed listener Socks listener on 127.0.0.1:9050
Jan 02 14:04:56.192 [Warning] Failed to parse/validate config: Failed to bind one of the listener ports.
Jan 02 14:04:56.192 [Error] Reading config failed--see warnings above.

Please note that I did not have an unusual configuration prior to this when everything was working, and that they simply stopped working after the new versions were upgraded by the package manager.

A discussion with another user on IRC brought up the claim that the upgrade changed vidalia's configuration to use a control socket in /var/run instead of the control port (which also broke their install). This seemed to be the case in my configuration as well.

My working solution:

  1. Open vidalia settings
  2. Click advanced
  3. Click Use TCP connect (ControlPort) instead of unix domain socket.
  4. Click ok and completely exit vidalia and reload

After these steps, Vidalia/tor worked together again.

comment:4 Changed 8 years ago by runa

I'll add that "sudo dpkg-reconfigure vidalia" doesn't even bring up any install questions.

comment:5 Changed 8 years ago by t|bo

The vidalia update sets the control socket to a location in /var/run/tor. On some systems (such as my Ubuntu 11.10) /var/run does not survive reboot, so /var/run/tor would need to be created with the proper permissions by root sometime before vidalia starts. /etc/init.d/tor has code that does this but only after verifying that Tor is running as daemon.

comment:6 Changed 8 years ago by ggallozz

I did just upated Vidali using Ubuntu Update Manager, TOR, Vidalia 0.2.9 and Polipo were already installed.

I don't have anymore Vidalia logs.

I've configured (since one year ago):

  • TOR control port 127.0.0.1:9051
  • TOR socks port 127.0.0.1:9050
  • TOR relay ports as default settings
  • Polipo HTTP/s proxy port 127.0.0.1:8118

comment:7 Changed 8 years ago by ggallozz

Priority: normalcritical

comment:8 Changed 8 years ago by ggallozz

what I discovered since that, is that the Tor Network Windows, doesn't show anymore the links (the yellow lines), just the planisphere alone.

comment:9 Changed 8 years ago by chiiph

Owner: changed from chiiph to dererk
Status: newassigned

Ok, so this is a packaging issue rather than vidalia.

ggallozz: your last comment is related to an internal change in tor, it will be solved with 0.2.18.

comment:10 Changed 8 years ago by dererk

Owner: changed from dererk to chiiph
Points: 4823

Root cause of this issue is explained on #4823 (See https://trac.torproject.org/projects/tor/ticket/4823).

Please see the documentation section "Default Configuration: Simplest and Painless", at /usr/share/doc/vidalia/README.Debian.gz (from version 0.2.17 and beyond).

comment:11 Changed 7 years ago by arma

Points: 4823
Priority: criticalnormal
Resolution: duplicate
Status: assignedclosed

In that case, I'm going to close this ticket as a duplicate of #4823. (The title and most of the discussion here doesn't help in resolving that ticket.)

Note: See TracTickets for help on using tickets.