Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4830 closed defect (not a bug)

Vidalia control panel's HIDE button, shows randomly times to times

Reported by: ggallozz Owned by: chiiph
Priority: Medium Milestone: Vidalia: 0.2.15
Component: Archived/Vidalia Version: Vidalia: 0.2.15
Severity: Keywords: interface
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

this happens randomly in v.0.2.9 and v.0.2.15

Ubuntu 10.10

Child Tickets

Attachments (1)

Screenshot.png (48.1 KB) - added by ggallozz 8 years ago.
Vidalia window without the [Hide] button

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by ggallozz

Component: - Select a componentVidalia
Keywords: interface added
Owner: set to chiiph

comment:2 Changed 8 years ago by chiiph

Could you provide a screenshot when it does hide? I can't reproduce this.

comment:3 in reply to:  2 Changed 8 years ago by ggallozz

Replying to chiiph:

Could you provide a screenshot when it does hide? I can't reproduce this.

Sorry, for now I can't, as it is in period "show".
anyway the Vidalia window is exactly as the one with [Hide] button, but whithout it, no any difference is visible more.

comment:4 Changed 8 years ago by chiiph

Status: newneeds_information

I understand, and although I believe you, there is no code in Vidalia that hides that part of the graphical interface, that's why I need a screenshot.

I will close this for now, unless you can give me any more information I can't really fix anything. Please re-open with a screenshot, o a way I can reproduce this if the problem persists.

Changed 8 years ago by ggallozz

Attachment: Screenshot.png added

Vidalia window without the [Hide] button

comment:5 Changed 8 years ago by ggallozz

Status: needs_informationassigned

here it is... ;-)

comment:6 Changed 8 years ago by chiiph

If you resize the window, does it appear? That layout has some size hints issues.

Can you reproduce this with 0.3.0 alpha? 0.3.1-alpha will be out quite soon, in case you want to try a less buggy version.

comment:7 Changed 8 years ago by ggallozz

In such case, resizing the windows vertically is not even possible, only horizontally, and this doesn't bring out the button anymore.

Sometimes, I would stress this meaning randomly, if Vidalia was started by the system startup procedure (as usually should), closing it and restarting it from the Apllications Menu / Internet / Vidalia, the button could appears, but, I repeat, the reproductibility is not assured.

For newer version, I wouldn't try some alpha version, as I reported in another ticket, I've already experienced problems with the v.2.9. So I'll wait for a new v.3 stable one.

comment:8 Changed 8 years ago by ggallozz

sorry, I would say I had problem with 2.15 update 'FROM' 2.9!

comment:9 Changed 8 years ago by chiiph

Resolution: not a bug
Status: assignedclosed

Ok, so, Vidalia doesn't display the hide checkbox when there is no system tray available.
Since Vidalia can't know whether the unavailability is only temporal, it hides the checkbox so users won't make the mistake of starting it hidden and have no tray icon to restore visibility.

You should see the checkbox again if you hide and restore Vidalia.

Sorry for the confusion, consider this as a safety feature rather than a random issue.

comment:10 Changed 8 years ago by ggallozz

No, it's not that way.
Indeed seems that it hides the HIDE button when started by a BASH script (that I use for all programs I want to run at the PC startup).

If I completely close Vidalia, then I launch it from Apllication/Internet/Vidalia menu path, the button is newly back ...

:-/

Note: See TracTickets for help on using tickets.