Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#4864 closed defect (not a bug)

ORPort configuration directive accepts address:port

Reported by: wwaites Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: tor-bridge
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Should perhaps just be port.

e.g.

ORPort 192.0.2.1:9001

This may be an artefact of the IPv6 support, cf.

ORPort [::]:9001

Specifying an IP address should likely require the job of ORListenAddress.

Child Tickets

Change History (3)

comment:1 Changed 8 years ago by nickm

Resolution: not a bug
Status: newclosed

This is actually working as intended; we want to deprecate ORListenAddress and have a way to provide multiple advertised addresses for an OR. Proposal 186 has more details.

comment:2 Changed 7 years ago by nickm

Keywords: tor-bridge added

comment:3 Changed 7 years ago by nickm

Component: Tor BridgeTor
Note: See TracTickets for help on using tickets.