Opened 8 years ago

Closed 2 years ago

#4872 closed defect (not a bug)

When the valid consensus is old but still barely valid, are the descriptors referenced in it still valid?

Reported by: Sebastian Owned by:
Priority: Very High Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-dirauth
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

If the answer is "no", then that might explain why the dirauths are now getting bombarded with traffic while we haven't had a valid consensus in > 18h. Also relevant to ideas extending the validity of consensuses

Child Tickets

Change History (10)

comment:1 Changed 7 years ago by nickm

Keywords: tor-auth added

comment:2 Changed 7 years ago by nickm

Component: Tor Directory AuthorityTor

comment:3 Changed 7 years ago by nickm

Milestone: Tor: unspecifiedTor: 0.2.5.x-final
Priority: normalcritical

comment:4 Changed 6 years ago by nickm

So, microdesc validity is "for a week after it was last listed." Microdescs can't be at fault here.

routerinfo_t validity is complicated; there's a lot of code that checks its published_on field. ROUTER_MAX_AGE is 48 hours, so might not be at fault, though we might have a rule to never prune a routerinfo_t in our current consensus if we don't have one. There are about 10 places that look at the 24-hour ROUTER_MAX_AGE_TO_PUBLISH, though, and I wonder whether all of them are correct.

comment:5 Changed 5 years ago by nickm

Milestone: Tor: 0.2.5.x-finalTor: 0.2.???

comment:6 Changed 3 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:7 Changed 3 years ago by nickm

Keywords: tor-03-unspecified-201612 added
Milestone: Tor: 0.3.???Tor: unspecified

Finally admitting that 0.3.??? was a euphemism for Tor: unspecified all along.

comment:8 Changed 2 years ago by nickm

Keywords: tor-03-unspecified-201612 removed

Remove an old triaging keyword.

comment:9 Changed 2 years ago by dgoulet

Keywords: tor-dirauth added; tor-auth removed

Turns out that tor-auth is for directory authority so make it clearer with tor-dirauth

comment:10 Changed 2 years ago by nickm

Resolution: not a bug
Severity: Normal
Status: newclosed

We still know we need to analyze old-consensus usage, but we have other tickets for that. Closing this one.

Note: See TracTickets for help on using tickets.