Opened 8 years ago

Closed 4 years ago

#4925 closed defect (fixed)

Windows can't run Vidalia Bundle and Tor Browser Bundle at the same time

Reported by: runa Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: needs-triage
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

A user is trying to set up a bridge with the Vidalia Bundle and use the Tor Browser Bundle for browsing etc. Setting up the Vidalia Bundle is not a problem and the bridge is up and running. When starting the Tor Browser Bundle, the browser never appears, and instead errors appear related to Tor not connecting to Vidalia due to path confusion. The Tor Browser Bundle works fine if the Vidalia Bundle is not already running.

I don't have OS X, so I can't really test this issue. See ticket 851 in RT for the full history and contact information for the user.

Child Tickets

Change History (11)

comment:1 in reply to:  description Changed 8 years ago by azumi

Replying to runa:

A user is trying to set up a bridge with the Vidalia Bundle and use the Tor Browser Bundle for browsing etc. Setting up the Vidalia Bundle is not a problem and the bridge is up and running. When starting the Tor Browser Bundle, the browser never appears, and instead errors appear related to Tor not connecting to Vidalia due to path confusion. The Tor Browser Bundle works fine if the Vidalia Bundle is not already running.

I don't have OS X, so I can't really test this issue. See ticket 851 in RT for the full history and contact information for the user.

I am able to use both the Vidalia Bundle and Tor Browser Bundle at the same time.
OSX 10.6.8
Vidalia Bundle 0.2.2.35-0.2.15
Tor Browser Bundle 2.2.35-4
I first started the Vidalia Bundle. Then started the Tor Browser Bundle and Aurora opened properly.

comment:2 Changed 8 years ago by runa

Resolution: not a bug
Status: newclosed

The user expected to be able to close Aurora and somehow restart it without exiting TBB. Closing this as not a bug.

comment:3 Changed 8 years ago by mo

Resolution: not a bug
Status: closedreopened
Summary: Mac OS X can't run Vidalia Bundle and Tor Browser Bundle at the same timeMac OS X and Windows can't run Vidalia Bundle and Tor Browser Bundle at the same time

I can confirm this bug at least on Windows: Vidalia is already running, say, configured as a bridge. The Tor Browser Bundle tries to launch a second instance of Vidalia, which fails to connect to the existing Tor (instead of launching a second instance of that as well?) and prompts for a password. It does not launch Aurora.

On tor-talk, people have also discussed launching TBB-Firefox directly. I tried that by running "FirefoxPortable\App\Firefox\tbb-firefox.exe --no-remote -profile .\Data\profile" inside the extracted directory. A Firefox window appears, but closes again very quickly.

comment:4 in reply to:  3 Changed 8 years ago by erinn

Replying to mo:

On tor-talk, people have also discussed launching TBB-Firefox directly. I tried that by running "FirefoxPortable\App\Firefox\tbb-firefox.exe --no-remote -profile .\Data\profile" inside the extracted directory. A Firefox window appears, but closes again very quickly.

This, at least, is by design. See #4192.

comment:5 Changed 8 years ago by mo

If I understand that fix correctly, it should quit only if the loaded profile is not a (the) TBB profile. The profile in "Data\profile" is the one shipped with the bundle (and sets torbrowser.version).

comment:6 Changed 8 years ago by mo

If I remove mike's patch, it still quits when trying to load the profile in Data\Profile. [It does not quit if I let it load my default profile (or create a new one with the profile manager).]

comment:7 Changed 7 years ago by arma

Summary: Mac OS X and Windows can't run Vidalia Bundle and Tor Browser Bundle at the same timeWindows can't run Vidalia Bundle and Tor Browser Bundle at the same time

comment:8 Changed 6 years ago by lunar

I think this one can be closed since Tor Browser Bundle is using 9150 as its proxy port nowadays. What do you think?

comment:9 Changed 6 years ago by arma

I think so too? But maybe a Windows user would let us know for sure.

comment:10 Changed 5 years ago by erinn

Keywords: needs-triage added

comment:11 Changed 4 years ago by cypherpunks

Resolution: fixed
Status: reopenedclosed

Vidalia is deprecated.

Note: See TracTickets for help on using tickets.