Opened 8 years ago

Closed 8 years ago

#4931 closed defect (duplicate)

Vidalia Relay Bundle running with the exit relay box checked

Reported by: runa Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: chiiph Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The Vidalia Relay Bundle is supposed to be a non-exit relay, and it is, but the box checked on the Sharing page is Relay traffic for the Tor network (exit relay). The configuration file looks like this:

# This file was generated by Tor; if you edit it, comments will not be preserved
# The old torrc file was renamed to torrc.orig.1 or similar, and Tor will ignore it

ControlPort 9051
DirPort 9030
DirReqStatistics 0
ExitPolicy reject *:*
Log notice stdout
Nickname default
ORPort 443
RelayBandwidthBurst 10485760
RelayBandwidthRate 5242880
SocksListenAddress 127.0.0.1

... so it doesn't look like we're running an exit relay, it's just the wrong box that's checked on the Sharing page.

Child Tickets

Change History (2)

comment:1 Changed 8 years ago by arma

Cc: chiiph added

Looks like a duplicate of #4642?

We really ought to get another Vidalia out with these fixes.

comment:2 Changed 8 years ago by runa

Resolution: duplicate
Status: newclosed

Yep, this is a duplicate of #4642.

Note: See TracTickets for help on using tickets.