Opened 8 years ago

Closed 7 years ago

#4936 closed defect (not a bug)

"Vidalia was unable to authenticate to the Tor software. (Control socket is not connected.)"

Reported by: bd59903 Owned by: chiiph
Priority: High Milestone:
Component: Archived/Vidalia Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I try to start Tor Browser (newest version), it returns "Vidalia was unable to authenticate to the Tor software. (Control socket is not connected.)" when trying to connect.

I made no new changes on my system prior to it, it just started happening.

Tor process is NOT running in the background. I have tried setting the authentication method to "cookie" or even "none." I have also tried setting a custom password.

I have tried disabling firewall/anti-virus/etc nothing seems to work.

Child Tickets

Attachments (1)

Tor Control Port issue.tiff (186.7 KB) - added by KIlledkennyagain 8 years ago.

Download all attachments as: .zip

Change History (18)

Changed 8 years ago by KIlledkennyagain

Attachment: Tor Control Port issue.tiff added

comment:1 Changed 8 years ago by KIlledkennyagain

Priority: normalmajor

Having the same issue with my Tor Browser bundle on OS X 10.6.8 was working fine then started having the authentication issue. I attached a screenshot of the error message.

comment:2 Changed 8 years ago by kalender

Are you still having the problem? I've had it since yesterday. Annoying stuff...

comment:3 Changed 8 years ago by kalender

Did a system recovery without any luck. Updated Windows.
The official TOR guys gotta know what the problem is? Wtf

comment:4 in reply to:  3 Changed 8 years ago by bd59903

Replying to kalender:

Did a system recovery without any luck. Updated Windows.
The official TOR guys gotta know what the problem is? Wtf

I reinstalled windows and it worked, but after i installed openvpn, it stopped working, not sure if was the cause though. Uninstalled it, still didnt work. so frustrating!

comment:5 in reply to:  3 ; Changed 8 years ago by KIlledkennyagain

Replying to kalender:

Did a system recovery without any luck. Updated Windows.
The official TOR guys gotta know what the problem is? Wtf

I uninstalled the program, downloaded it again, and it is working fine now. Perhaps the new download was an updated version (But I'm not sure).

comment:6 in reply to:  3 Changed 8 years ago by runa

Replying to kalender:

Did a system recovery without any luck. Updated Windows.

Is this Windows XP?

comment:7 in reply to:  5 Changed 8 years ago by bd59903

So reinstalled my OS again. It worked for about a day then stopped again. I did nothing around the time it stopped to my system. So for some reason something or someone is blocking it after several hours.

comment:8 Changed 8 years ago by bd59903

if I had to edit my windows host file with something like:
127.0.0.1 *.com
would that affect tor browser? I notice that is the same ip as is in vidalia settings, though as it is just the local i dont know why.

comment:9 Changed 8 years ago by mikeperry

Component: Tor BrowserVidalia
Keywords: connection control socket removed
Owner: changed from mikeperry to chiiph
Version: Tor: unspecified

Chiiph: For what it's worth, I also occasionally have issues like this with the Linux TBB, especially after a reboot if my laptop crashed/ran out of battery while Vidalia was open.

comment:10 Changed 8 years ago by chiiph

Could it be that the socket file is left in a certain state and if the tor process exits without cleaning, the next time tor tries to use it, the socket seems like is already in use?

comment:11 Changed 8 years ago by bd59903

but it still happens even if use completely fresh tor browser package

comment:12 in reply to:  11 ; Changed 8 years ago by runa

Replying to bd59903:

but it still happens even if use completely fresh tor browser package

Do you still have OpenVPN installed on your system?

comment:13 in reply to:  12 Changed 8 years ago by bd59903

Replying to runa:

Replying to bd59903:

but it still happens even if use completely fresh tor browser package

Do you still have OpenVPN installed on your system?

no, the only i found to fix it was to do a fresh OS install. when i did that it worked for about a day, then just started giving the same message. When it did this, I had left it on over night and when i woke up it wasnt working. did not even have openvpn installed on computer after fresh OS install. could there have been a connection problem overnight and something on my system or provider somehow blocked it to prevent errors or something?

comment:14 Changed 8 years ago by bd59903

well since no one seems to know what the problem is much less how to fix it, does anyone know of another way to connect to tor?

comment:15 in reply to:  14 Changed 8 years ago by bd59903

Replying to bd59903:

well since no one seems to know what the problem is much less how to fix it, does anyone know of another way to connect to tor?

and yes there is, AdvOR, has folder in download with instructions and config file to connect to TOR using part of the tor browser bundle.

comment:16 Changed 7 years ago by VenZe

Could you try to run next command in administrative cmd:
netsh winsock reset
reboot computer and test if problem persists.

comment:17 Changed 7 years ago by arma

Resolution: not a bug
Status: newclosed

I'm going to close this ticket, since it is a generic "my Tor failed to start for some reason" ticket. I suggest looking at Vidalia's message log window in this case, or otherwise trying to get rid of services that might be conflicting with Tor's choice of ports.

Note: See TracTickets for help on using tickets.