Opened 7 years ago

Closed 6 years ago

#4952 closed defect (duplicate)

managed proxies: "[notice] Failed to terminate process with PID '%d'" when doing Ctrl-c from terminal

Reported by: asn Owned by:
Priority: Low Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Keywords: tor-bridge
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I noticed the following in my logs:

"[notice] Failed to terminate process with PID '%d'"

while I was testing managed proxies.

This happened because I terminate tor by doing Ctrl-c in a terminal, which sends a SIGINT to the whole process group (including obfpsroxy). This kills obfsproxy. Then, when I kill tor with a second Ctrl-c, tor tries to terminate all the managed proxies which are already dead. This prints the above line.

Maybe this is not even a bug, but I think it could be a good idea to tone down the log severity to info, when errno is ESRCH.

In any case, we should print the errno string along with the error message.

Child Tickets

Change History (5)

comment:1 Changed 7 years ago by asn

This will probably need some refactoring to fix, since the log message is currently issued by tor_process_handle_destroy().

The cleanest fix I can think of at the moment, is not terminating the process inside tor_process_handle_destroy() and having its callers terminate the process (and handle failures) themselves.

comment:2 Changed 7 years ago by nickm

Keywords: tor-bridge added

comment:3 Changed 7 years ago by nickm

Component: Tor BridgeTor

comment:4 Changed 6 years ago by arma

Looks very related to #8746.

comment:5 Changed 6 years ago by nickm

Resolution: duplicate
Status: newclosed

Closed as a duplicate of #8746

Note: See TracTickets for help on using tickets.